Bug 968755 - [abrt] cinnamon-1.8.3-1.fc19: subprocess.py:1308:_execute_child:OSError: [Errno 2] No such file or directory
[abrt] cinnamon-1.8.3-1.fc19: subprocess.py:1308:_execute_child:OSError: [Err...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:a1d02c0dfe1558f2e7678baed61...
:
: 969218 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 20:39 EDT by sgiurgiu11
Modified: 2013-07-27 21:04 EDT (History)
4 users (show)

See Also:
Fixed In Version: nemo-1.8.4-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 02:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.45 KB, text/plain)
2013-05-29 20:40 EDT, sgiurgiu11
no flags Details
File: core_backtrace (316 bytes, text/plain)
2013-05-29 20:40 EDT, sgiurgiu11
no flags Details
File: environ (1.44 KB, text/plain)
2013-05-29 20:40 EDT, sgiurgiu11
no flags Details

  None (edit)
Description sgiurgiu11 2013-05-29 20:39:56 EDT
Description of problem:
Right click on the Cinnanmon Menu icon. Chose Edit Menu. Selected the Programming group. Clicked "New Item".

Version-Release number of selected component:
cinnamon-1.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python -OOt /usr/bin/cinnamon-menu-editor
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /usr/bin/cinnamon-menu-editor
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
subprocess.py:1308:_execute_child:OSError: [Errno 2] No such file or directory

Traceback (most recent call last):
  File "/usr/lib/cinnamon-menu-editor/cme/MainWindow.py", line 277, in on_new_item_button_clicked
    process = subprocess.Popen(['gnome-desktop-item-edit', file_path], env=os.environ)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1308, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
errread: None
c2pread: None
gc_was_enabled: True
errwrite: None
shell: False
errpipe_write: 13
executable: 'gnome-desktop-item-edit'
close_fds: False
self: <subprocess.Popen object at 0x27e7850>
env: {'SSH_ASKPASS': '/usr/libexec/openssh/gnome-ssh-askpass', 'KDE_IS_PRELINKED': '1', 'GNOME_DESKTOP_SESSION_ID': 'this-is-deprecated', 'GJS_DEBUG_OUTPUT': 'stderr', 'LESSOPEN': '||/usr/bin/lesspipe.sh %s', 'QT_IM_MODULE': 'ibus', 'LOGNAME': 'sergiu', 'USER': 'sergiu', 'GNOME_KEYRING_CONTROL': '/run/user/1000/keyring-v13xXw', 'XDG_VTNR': '1', 'PATH': '/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin', 'HISTSIZE': '1000', 'DISPLAY': ':0', 'SSH_AGENT_PID': '2057', 'LANG': 'en_US.utf8', 'CCACHE_HASHDIR': '', 'TERM': 'dumb', 'SHELL': '/bin/bash', 'XAUTHORITY': '/run/gdm/auth-for-sergiu-CyKGSA/database', 'SESSION_MANAGER': 'local/unix:@/tmp/.ICE-unix/1919,unix/unix:/tmp/.ICE-unix/1919', 'SHLVL': '1', 'CLUTTER_DISABLE_XINPUT': '1', 'WINDOWPATH': '1', 'QT_PLUGIN_PATH': '/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins', 'IMSETTINGS_INTEGRATE_DESKTOP': 'yes', 'GIO_LAUNCHED_DESKTOP_FILE_PID': '2207', 'GPG_AGENT_INFO': '/run/user/1000/keyring-v13xXw/gpg:0:1', 'HOME': '/home/sergiu', 'USERNAME': 'sergiu', 'IMSETTINGS_MODULE': 'none', 'GIO_LAUNCHED_DESKTOP_FILE': '/usr/share/applications/cinnamon.desktop', 'XDG_RUNTIME_DIR': '/run/user/1000', 'SSH_AUTH_SOCK': '/run/user/1000/keyring-v13xXw/ssh', 'CINNAMON_VERSION': '1.8.3', 'GDMSESSION': 'cinnamon', 'XMODIFIERS': '@im=ibus', 'XDG_MENU_PREFIX': 'gnome-', 'QT_GRAPHICSSYSTEM_CHECKED': '1', 'XDG_SESSION_ID': '1', 'DBUS_SESSION_BUS_ADDRESS': 'unix:abstract=/tmp/dbus-VaU0zhV9uH,guid=669f567023b3731faa09da3551a69c25', '_': '/usr/bin/gnome-session-cinnamon', 'KDEDIRS': '/usr', 'DESKTOP_SESSION': 'cinnamon', 'GNOME_KEYRING_PID': '1917', 'KRB5CCNAME': 'DIR:/run/user/1000/krb5cc_e38ca229aa0b46872fa36c1a51a69c1a', 'HOSTNAME': 'sergiu-pc', 'GDM_LANG': 'en_US.utf8', 'HISTCONTROL': 'ignoredups', 'PWD': '/home/sergiu', 'CVS_RSH': 'ssh', 'MAIL': '/var/spool/mail/sergiu', 'GJS_DEBUG_TOPICS': 'JS ERROR;JS LOG', 'XDG_SEAT': 'seat0'}
cwd: None
child_exception: OSError(2, 'No such file or directory')
args: ['gnome-desktop-item-edit', '/home/sergiu/.local/share/applications/alacarte-made-43eb8e5c-c8c0-11e2-96e4-50465d71647e.desktop']
c2pwrite: None
data: 'cexceptions\nOSError\np0\n(I2\nS\'No such file or directory\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1265, in _execute_child\\n    os.execvpe(executable, args, env)\\n  File "/usr/lib64/python2.7/os.py", line 353, in execvpe\\n    _execvpe(file, args, env)\\n  File "/usr/lib64/python2.7/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] No such file or directory\\n\'\np6\nsb.'
creationflags: 0
errpipe_read: 12
preexec_fn: None
p2cread: None
startupinfo: None
p2cwrite: None
universal_newlines: False
Comment 1 sgiurgiu11 2013-05-29 20:40:04 EDT
Created attachment 754592 [details]
File: backtrace
Comment 2 sgiurgiu11 2013-05-29 20:40:11 EDT
Created attachment 754593 [details]
File: core_backtrace
Comment 3 sgiurgiu11 2013-05-29 20:40:14 EDT
Created attachment 754594 [details]
File: environ
Comment 4 leigh scott 2013-05-30 02:13:06 EDT
This is caused by gnome-3.8 changes and will ned fixing upstream, please report the issue here instead.

https://github.com/linuxmint/Cinnamon/issues
Comment 5 leigh scott 2013-05-30 19:44:35 EDT
*** Bug 969218 has been marked as a duplicate of this bug. ***
Comment 6 Gwendal 2013-05-31 12:49:02 EDT
Was this bug reported to cinnamon dev team?

Does anyone have a workaround to edit the menu in the meantime?
Comment 7 sgiurgiu11 2013-05-31 12:57:17 EDT
Yes, it was reported to the Cinnamon team. They are aware of that and are working on it.

https://github.com/linuxmint/Cinnamon/issues/2098
Comment 8 Gwendal 2013-05-31 12:59:18 EDT
(In reply to sgiurgiu11 from comment #7)
> Yes, it was reported to the Cinnamon team. They are aware of that and are
> working on it.
> 
> https://github.com/linuxmint/Cinnamon/issues/2098

Good to hear. Thanks :).
Comment 9 Fedora Update System 2013-07-16 15:18:28 EDT
cinnamon-1.9.1-17.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-17.fc19
Comment 10 Fedora Update System 2013-07-27 21:04:00 EDT
nemo-1.8.4-2.fc19, cinnamon-1.9.1-19.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.