Bug 969218 - [abrt] cinnamon-1.8.3-1.fc19: subprocess.py:1308:_execute_child:OSError: [Errno 2] File o directory non esistente
[abrt] cinnamon-1.8.3-1.fc19: subprocess.py:1308:_execute_child:OSError: [Err...
Status: CLOSED DUPLICATE of bug 968755
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:fb456d46280194baa5f805adb8f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 18:49 EDT by Andrea Oliveri
Modified: 2013-05-30 19:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 19:44:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.58 KB, text/plain)
2013-05-30 18:49 EDT, Andrea Oliveri
no flags Details
File: core_backtrace (443 bytes, text/plain)
2013-05-30 18:49 EDT, Andrea Oliveri
no flags Details
File: environ (1.57 KB, text/plain)
2013-05-30 18:49 EDT, Andrea Oliveri
no flags Details

  None (edit)
Description Andrea Oliveri 2013-05-30 18:49:27 EDT
Description of problem:
I try to obtain the property of an element in Main Menu Editor

Version-Release number of selected component:
cinnamon-1.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python -OOt /usr/bin/cinnamon-menu-editor
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /usr/bin/cinnamon-menu-editor
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
subprocess.py:1308:_execute_child:OSError: [Errno 2] File o directory non esistente

Traceback (most recent call last):
  File "/usr/lib/cinnamon-menu-editor/cme/MainWindow.py", line 518, in on_properties_button_clicked
    self.on_edit_properties_activate(None)
  File "/usr/lib/cinnamon-menu-editor/cme/MainWindow.py", line 315, in on_edit_properties_activate
    process = subprocess.Popen(['gnome-desktop-item-edit', file_path], env=os.environ)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1308, in _execute_child
    raise child_exception
OSError: [Errno 2] File o directory non esistente

Local variables in innermost frame:
errread: None
c2pread: None
gc_was_enabled: True
errwrite: None
shell: False
errpipe_write: 11
executable: 'gnome-desktop-item-edit'
close_fds: False
self: <subprocess.Popen object at 0x2743ad0>
env: {'LC_NUMERIC': 'it_IT.UTF-8', 'GNOME_DESKTOP_SESSION_ID': 'this-is-deprecated', 'GJS_DEBUG_OUTPUT': 'stderr', 'LESSOPEN': '||/usr/bin/lesspipe.sh %s', 'XDG_VTNR': '1', 'QT_IM_MODULE': 'ibus', 'LOGNAME': 'andrea', 'USER': 'andrea', 'GNOME_KEYRING_CONTROL': '/home/andrea/.cache/keyring-h7OeUE', 'LC_PAPER': 'it_IT.UTF-8', 'PATH': '/usr/lib64/ccache:/usr/libexec/lightdm:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/andrea/.local/bin:/home/andrea/bin', 'HISTSIZE': '1000', 'DISPLAY': ':0', 'SSH_AGENT_PID': '4143', 'LANG': 'it_IT.utf8', 'CCACHE_HASHDIR': '', 'TERM': 'dumb', 'SHELL': '/bin/bash', 'XDG_SESSION_PATH': '/org/freedesktop/DisplayManager/Session1', 'XAUTHORITY': '/var/run/lightdm/andrea/xauthority', 'SESSION_MANAGER': 'local/unix:@/tmp/.ICE-unix/4006,unix/unix:/tmp/.ICE-unix/4006', 'LC_MONETARY': 'it_IT.UTF-8', 'CLUTTER_DISABLE_XINPUT': '1', 'IMSETTINGS_INTEGRATE_DESKTOP': 'yes', 'GIO_LAUNCHED_DESKTOP_FILE_PID': '4198', 'GPG_AGENT_INFO': '/home/andrea/.cache/keyring-h7OeUE/gpg:0:1', 'HOME': '/home/andrea', 'IMSETTINGS_MODULE': 'none', 'SHLVL': '1', 'GIO_LAUNCHED_DESKTOP_FILE': '/usr/share/applications/cinnamon.desktop', 'XDG_RUNTIME_DIR': '/run/user/1000', 'SSH_AUTH_SOCK': '/home/andrea/.cache/keyring-h7OeUE/ssh', 'CINNAMON_VERSION': '1.8.3', 'GDMSESSION': 'cinnamon', 'XMODIFIERS': '@im=ibus', 'XDG_MENU_PREFIX': 'gnome-', 'XDG_SEAT_PATH': '/org/freedesktop/DisplayManager/Seat0', 'QT_GRAPHICSSYSTEM_CHECKED': '1', 'XDG_SESSION_ID': '2', 'DBUS_SESSION_BUS_ADDRESS': 'unix:abstract=/tmp/dbus-QE7EMynZB4,guid=b2d982fb825b22a17de2bf9451a7d651', '_': '/usr/bin/gnome-session-cinnamon', 'DESKTOP_SESSION': 'cinnamon', 'GNOME_KEYRING_PID': '4002', 'HOSTNAME': 'wintermute', 'HISTCONTROL': 'ignoredups', 'LC_MEASUREMENT': 'it_IT.UTF-8', 'PWD': '/home/andrea', 'MAIL': '/var/spool/mail/andrea', 'LC_TIME': 'it_IT.UTF-8', 'GJS_DEBUG_TOPICS': 'JS ERROR;JS LOG', 'XDG_SEAT': 'seat0'}
cwd: None
child_exception: OSError(2, 'File o directory non esistente')
args: ['gnome-desktop-item-edit', '/home/andrea/.local/share/applications/im-chooser.desktop']
c2pwrite: None
data: 'cexceptions\nOSError\np0\n(I2\nS\'File o directory non esistente\'\np1\ntp2\nRp3\n(dp4\nS\'child_traceback\'\np5\nS\'Traceback (most recent call last):\\n  File "/usr/lib64/python2.7/subprocess.py", line 1265, in _execute_child\\n    os.execvpe(executable, args, env)\\n  File "/usr/lib64/python2.7/os.py", line 353, in execvpe\\n    _execvpe(file, args, env)\\n  File "/usr/lib64/python2.7/os.py", line 380, in _execvpe\\n    func(fullname, *argrest)\\nOSError: [Errno 2] File o directory non esistente\\n\'\np6\nsb.'
creationflags: 0
errpipe_read: 10
preexec_fn: None
p2cread: None
startupinfo: None
p2cwrite: None
universal_newlines: False
Comment 1 Andrea Oliveri 2013-05-30 18:49:33 EDT
Created attachment 755083 [details]
File: backtrace
Comment 2 Andrea Oliveri 2013-05-30 18:49:37 EDT
Created attachment 755084 [details]
File: core_backtrace
Comment 3 Andrea Oliveri 2013-05-30 18:49:40 EDT
Created attachment 755085 [details]
File: environ
Comment 4 leigh scott 2013-05-30 19:44:34 EDT

*** This bug has been marked as a duplicate of bug 968755 ***

Note You need to log in before you can comment on or make changes to this bug.