Bug 968916 - qemu-guest-agent-win32 package is hardly usable
qemu-guest-agent-win32 package is hardly usable
Status: CLOSED DUPLICATE of bug 971141
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
x86_64 Windows
unspecified Severity medium
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 05:31 EDT by Peter Krempa
Modified: 2013-06-05 15:24 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 15:24:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Krempa 2013-05-30 05:31:53 EDT
Description of problem:
The qemu-guest-agent-win32 provides only one dynamically linked exe file in the filesystem of the host. The guest agent is cumbersome to transfer to the windows host and requires severe manual interaction to install supporting libraries.

Version-Release number of selected component (if applicable):
qemu-guest-agent-win32-0.12.1.2-2.371.el6.x86_64

How reproducible:
Always.

Actual results:
$ ls /usr/share/qemu-kvm/qemu-ga-win32/ -l
total 484
-rwxr-xr-x. 1 root root 490506 May 27 15:09 qemu-ga.exe
-r--r--r--. 1 root root   1155 May 27 15:02 README.txt

After transferring the file into the guest via 3 party software, the user has to spend time looking for the correct versions of libraries.

google searches for DLL library names (this is the usual approach a user takes) lead often to untrusted sites and the downloaded DLLs may contain malware (and are executed with administrator privileges).

Expected results:
Along with the original binary we should distribute a iso image containing the executable. Additionally the executable should be either statically linked or dynamic libraries (or installers for the libraries) should be provided in this package.

Additional info:
Virtio-win drivers needed for the virtio channel to the guest agent are distributed as a ISO image.
Comment 2 Ademar Reis 2013-06-03 13:51:07 EDT
qemu-ga-win32 is a tech-preview in 6.4 and the README documents from where the .dlls should be extracted.

We're working to deliver it in the same iso of the other windows components a guest may be interested, AKA the virtio-win iso.
Comment 4 Ademar Reis 2013-06-05 15:24:38 EDT
Marking as duplicate of bug 971141 because the requirements are more clear there.

*** This bug has been marked as a duplicate of bug 971141 ***

Note You need to log in before you can comment on or make changes to this bug.