Bug 971141 - [6.5 FEAT] qemu guest agent installer for windows
[6.5 FEAT] qemu guest agent installer for windows
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: FutureFeature
: 968916 (view as bug list)
Depends On:
Blocks: 831387
  Show dependency treegraph
 
Reported: 2013-06-05 15:21 EDT by Ademar Reis
Modified: 2013-11-21 19:12 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Windows Guest Agent Fully Supported The Windows guest agent is now fully supported and delivered with its own installer in the Supplementary channel together with virtio-win drivers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 19:12:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ademar Reis 2013-06-05 15:21:06 EDT
We're looking for an installer for the qemu guest agent for Windows. The current approach is very simple: users get it from an RPM package on Linux (host) and have the responsibility of copying the .dlls and the .exe to the Windows guest.

Our intention is to add it to a virtio-win installer, which would include all the virtio drivers and guest agents for Windows.
Comment 2 Ademar Reis 2013-06-05 15:24:38 EDT
*** Bug 968916 has been marked as a duplicate of this bug. ***
Comment 9 Qunfang Zhang 2013-08-08 22:54:24 EDT
Yan, 
The qemu-ga.exe file in the virtio-win iso can be installed on both 32bit and 64bit windows guest.
Comment 26 Qunfang Zhang 2013-10-09 04:44:38 EDT
Just tried to install the qemu-ga Yan provided. But hit the following 

c:\qemu-ga>qemu-ga.exe --service install
failed to load COMRegister from qga-vss.dll: The specified procedure could not b
e found.


So, I removed the qga-vss.dll file and re-install again:

c:\qemu-ga>qemu-ga.exe --service install
failed to load qga-vss.dll: The specified module could not be found.
fsfreeze is disabled
Installation of VSS provider is skipped. fsfreeze will be disabled.
** (qemu-ga.exe:1252): DEBUG: service's cmdline: "c:\qemu-ga\qemu-ga.exe" -d
Service was installed successfully.

But failed to start the service:

c:\qemu-ga>
c:\qemu-ga>net start qemu-ga
System error 5 has occurred.

Access is denied.

My CLI:
]#  /usr/libexec/qemu-kvm -M rhel6.5.0 -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -enable-kvm -name t2-rhel6.4-32 -uuid 61b6c504-5a8b-4fe1-8347-6c929b750dde -k en-us -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0 -drive file=/home/win7-32-virtio.qcow2,if=none,id=disk0,format=qcow2,werror=stop,rerror=stop,aio=native -device ide-drive,bus=ide.0,unit=1,drive=disk0,id=disk0  -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,drive=drive-ide0-1-0,bus=ide.1,unit=0,id=cdrom -netdev tap,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=44:37:E6:5E:91:85,bus=pci.0,addr=0x5 -monitor stdio -qmp tcp:0:6666,server,nowait -chardev socket,path=/tmp/isa-serial,server,nowait,id=isa1 -device isa-serial,chardev=isa1,id=isa-serial1 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x8 -chardev socket,id=charchannel0,path=/tmp/serial-socket,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,path=/tmp/foo,server,nowait,id=foo -device virtconsole,chardev=foo,id=console0 -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 -spice port=5930,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -k en-us -boot c -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device virtserialport,bus=virtio-serial0.0,chardev=qga0,name=org.qemu.guest_agent.0  -global  PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0

Host: 

[root@localhost home]# uname -r
2.6.32-422.el6.x86_64
[root@localhost home]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.411.el6.x86_64

Guest virtio-serial version: virtio-win-prewhql-72


Yan, could you help check?  Thanks!
Comment 27 Yan Vugenfirer 2013-10-09 05:13:21 EDT
(In reply to Qunfang Zhang from comment #26)
> Just tried to install the qemu-ga Yan provided. But hit the following 
> 
> c:\qemu-ga>qemu-ga.exe --service install
> failed to load COMRegister from qga-vss.dll: The specified procedure could
> not b
> e found.

> 
> But failed to start the service:
> 
> c:\qemu-ga>
> c:\qemu-ga>net start qemu-ga
> System error 5 has occurred.
> 
> Access is denied.
> 

Hi,

Are you running from elevated command line? Try to run cmd as Administrator. I think this is an issue (can be also for the first failure as well).

Also can you check that you can start the service from service manager? (Might depend on exact Windows OS, on the latest ones run services.msc).

Best regards,
Yan.
Comment 28 Qunfang Zhang 2013-10-09 05:21:32 EDT
Yan,

I'm just running the command as Administrator and I re-test again with the older qemu-ga.exe extracted from qemu-kvm-389 build, succeed.  And tried to start the service from service manager with your qemu-ga build, same error pops up as "Access is denied".
Comment 29 Qunfang Zhang 2013-10-10 23:29:07 EDT
Hi, Yan

Do you find this problem and the reason? Or there's something wrong with my steps?

Thanks,
Qunfang
Comment 30 RHEL Product and Program Management 2013-10-14 21:38:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 32 Qunfang Zhang 2013-10-22 04:36:04 EDT
Hi, Yan

Please help provide an official build to QE asap as the status is already ON_QA. 


Thanks,
Qunfang
Comment 37 Qunfang Zhang 2013-10-27 05:28:17 EDT
I will set the bug to VERIFIED first according to comment 36 as there's no test blocker or regression bug for windows virtagent. And for the two new bugs, they are deferred to 6.6 with a reasonable comment in those BZs. 

Hi, Vadim

Could you help add this bug to rhel6.5 virtio-win errata? 

Thanks,
Qunfang
Comment 39 Qunfang Zhang 2013-10-28 01:36:53 EDT
The functionality is verified pass, however I will change the status back to ON_QA until it's confirmed that the virtio-win package is built and include it.
Comment 40 Vadim Rozenfeld 2013-10-28 02:41:36 EDT
(In reply to Qunfang Zhang from comment #37)
> I will set the bug to VERIFIED first according to comment 36 as there's no
> test blocker or regression bug for windows virtagent. And for the two new
> bugs, they are deferred to 6.6 with a reasonable comment in those BZs. 
> 
> Hi, Vadim
> 
> Could you help add this bug to rhel6.5 virtio-win errata? 
> 
> Thanks,
> Qunfang

Tried, get the following result:

1 error prohibited this update advisory form from being saved

There were problems with the following fields:

    Idsfixed Bug #971141 does not have the correct flags. Requires rhel-6.5.0,devel_ack,qa_ack,pm_ack but only has blocker?,devel_ack+,pm_ack+,qa_ack+,qe_test_coverage?,requires_doc_text+,rhel-6.5.0?.
Comment 41 Qunfang Zhang 2013-10-28 02:45:16 EDT
(In reply to Vadim Rozenfeld from comment #40)
> (In reply to Qunfang Zhang from comment #37)
> > I will set the bug to VERIFIED first according to comment 36 as there's no
> > test blocker or regression bug for windows virtagent. And for the two new
> > bugs, they are deferred to 6.6 with a reasonable comment in those BZs. 
> > 
> > Hi, Vadim
> > 
> > Could you help add this bug to rhel6.5 virtio-win errata? 
> > 
> > Thanks,
> > Qunfang
> 
> Tried, get the following result:
> 
> 1 error prohibited this update advisory form from being saved
> 
> There were problems with the following fields:
> 
>     Idsfixed Bug #971141 does not have the correct flags. Requires
> rhel-6.5.0,devel_ack,qa_ack,pm_ack but only has
> blocker?,devel_ack+,pm_ack+,qa_ack+,qe_test_coverage?,requires_doc_text+,
> rhel-6.5.0?.


Maybe we need PM to help add rhel6.5.0+ and blocker+ flags?
Comment 42 Qunfang Zhang 2013-10-28 03:05:59 EDT
Hello, PM

We need this bug in rhel6.5 and it's fixed already, could you help provide the "rhel-6.5.0+" and "blocker+" flags for us? 

Thanks,
Qunfang
Comment 43 Qunfang Zhang 2013-10-29 00:55:56 EDT
Hi, Tom

Thanks you for helping with the flags stuff, and there's another bug need you guys' help, could you help do it? 

Bug 948017 - VSS support for qemu-ga-win

Thanks,
Qunfang
Comment 45 Qunfang Zhang 2013-10-30 01:10:06 EDT
# rpm -ivh virtio-win-1.6.7-2.el6.noarch.rpm 
Preparing...                ########################################### [100%]
   1:virtio-win             ########################################### [100%]
# cd /usr/share/virtio-win/
]# ls
drivers                     virtio-win-1.6.7.iso      virtio-win.iso
guest-agent                 virtio-win-1.6.7_x86.vfd  virtio-win_x86.vfd
virtio-win-1.6.7_amd64.vfd  virtio-win_amd64.vfd
# cd guest-agent/
# ls
qemu-ga-x64.msi  qemu-ga-x86.msi
# 
# md5sum *
1c98e5435d5900e88bf608aad41a6c6e  qemu-ga-x64.msi
a1d26b4534c2d5aff17255497adbf218  qemu-ga-x86.msi


md5sum for the MSIs in build qemu-ga-win-6.5-4:

[root@qzhang-pc qemu-ga-win-6.5-4]# md5sum *
1c98e5435d5900e88bf608aad41a6c6e  qemu-ga-x64.msi
a1d26b4534c2d5aff17255497adbf218  qemu-ga-x86.msi

As the two msi files have been integrated into virtio-win package, I would like to set this bug status to VERIFIED.
Comment 47 errata-xmlrpc 2013-11-21 19:12:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html

Note You need to log in before you can comment on or make changes to this bug.