Bug 969065 - engine: CanDoAction for LSM when vm is stateless is logged in engine log no dialogue pops up in webadmin
engine: CanDoAction for LSM when vm is stateless is logged in engine log no d...
Status: CLOSED DUPLICATE of bug 926959
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Ayal Baron
Haim
storage
:
: 926963 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 11:03 EDT by Dafna Ron
Modified: 2016-02-10 11:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 13:32:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (163.02 KB, application/x-gzip)
2013-05-30 11:03 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2013-05-30 11:03:19 EDT
Created attachment 754921 [details]
logs

Description of problem:

if we try live migrate a disk of a stateless vm it appears as if the command is sent but nothing happens. 
looking at the engine log we can see that there is a CanDoAction but no dialogue pops up in webadmin. 

this is not related to other bugs who do not show dialogue after ovirt-engine restart + login without reload because other CanDoAction alerts are shown. 

Version-Release number of selected component (if applicable):

sf17

How reproducible:

100%

Steps to Reproduce:
1. create a stateless vm and run it 
2. try to LSM the disk
3.

Actual results:

no error is shown to the user but nothing happens. 
looking at the engine log there is a CanDoAction but no dialogue appears to the user. 

Expected results:

a CanDoAction dialogue should appear with appropriate error. 

Additional info: log

013-05-30 17:55:19,783 WARN  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (pool-4-thread-49) [1016eccd] CanDoAction of action CreateAllSnapshotsFromVm failed. Reasons:VAR__ACTION__CREATE,VAR__TYPE__SNAPSHOT,ACTION_TYPE_FAILED_VM_RUNNING_STATELESS
Comment 1 Daniel Erez 2013-05-31 13:32:00 EDT

*** This bug has been marked as a duplicate of bug 926959 ***
Comment 2 Daniel Erez 2013-07-04 07:05:23 EDT
*** Bug 926963 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.