Bug 969280 - Removing a subscription from rhsm GUI will cause a traceback when the system is offline
Removing a subscription from rhsm GUI will cause a traceback when the system ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-31 02:45 EDT by xingge
Modified: 2016-09-19 22:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:10:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm log when error happens (939.81 KB, text/x-log)
2013-05-31 02:45 EDT, xingge
no flags Details
Taceback thrown (9.45 KB, application/msword)
2013-06-05 17:09 EDT, Sharath Dwaral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1332 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-09-30 18:49:24 EDT

  None (edit)
Description xingge 2013-05-31 02:45:39 EDT
Created attachment 755176 [details]
rhsm log when error happens

Description of problem:
The system should be attached some subscriptions and offline, when use remove button in rhsm gui to unsubscribe subscriptions, it will cause a traceback.

Version-Release number of selected component (if applicable):
subscription-manager-1.8.8-1.el5
subscription-manager-gui-1.8.8-1.el5
subscription-manager-firstboot-1.8.8-1.el5
python-rhsm-1.8.11-1.el5

How reproducible:
always

Steps to Reproduce:
1.The system is registered and attached some subscriptions

2.Make the system offline, I use
#service network stop

3.Open the rhsm gui in CLI
#subscription-manager-gui

4.Try to remove some subscriptions.
Go to "My subscriptions" tab and click the "remove" button on the right bottom.

Actual results:
Get a traceback like below:
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 137, in _on_unsubscribe_prompt_response
    self.backend.certlib.update()
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 69, in update
    return self._do_update()
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 92, in _do_update
    return action.perform()
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 236, in perform
    expected = self._get_expected_serials(report)
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 318, in _get_expected_serials
    exp = self.get_certificate_serials_list()
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 311, in get_certificate_serials_list
    reply = self.uep.getCertificateSerials(self._get_consumer_id())
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 811, in getCertificateSerials
    return self.conn.request_get(method)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 481, in request_get
    return self._request("GET", method)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 422, in _request
    conn.request(request_type, handler, body=body, headers=headers)
  File "/usr/lib64/python2.4/httplib.py", line 810, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.4/httplib.py", line 833, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.4/httplib.py", line 804, in endheaders
    self._send_output()
  File "/usr/lib64/python2.4/httplib.py", line 685, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.4/httplib.py", line 652, in send
    self.connect()
  File "/usr/lib64/python2.4/site-packages/M2Crypto/httpslib.py", line 49, in connect
    for (family, _, _, _, _) in \
socket.gaierror: (-2, 'Name or service not known')

Expected results:
No traceback message will shown.

Additional info:
Comment 1 RHEL Product and Program Management 2013-05-31 03:05:20 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Carter Kozak 2013-06-04 13:12:24 EDT
commit 602f10f8b060d03183c32f0a01b6368182ed7a12
Author: ckozak <ckozak@redhat.com>
Date:   Fri May 31 10:08:21 2013 -0400

    969280: Fix traceback on disconnected sub detach
Comment 3 Jesus M. Rodriguez 2013-06-04 15:57:27 EDT
fixed in subscription-manager 1.8.10-1
Comment 4 Bryan Kearney 2013-06-05 08:36:03 EDT
Moving all modified bugs to ON_QA
Comment 5 Sharath Dwaral 2013-06-05 17:09:54 EDT
Created attachment 757371 [details]
Taceback thrown

Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
python-rhsm-1.8.12-1.git.0.d747a65.el5
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-gui-1.8.10-1.git.1.b44c4b1.el5
subscription-manager-migration-1.8.10-1.git.1.b44c4b1.el5
subscription-manager-firstboot-1.8.10-1.git.1.b44c4b1.el5
subscription-manager-1.8.10-1.git.1.b44c4b1.el5

Steps followed:

1.The system is registered and attached some subscriptions

2.Make the system offline, I use
#service network stop

3.Open the rhsm gui in CLI
#subscription-manager-gui

4.Try to remove some subscriptions.
Go to "My subscriptions" tab and click the "remove" button on the right bottom.

Actual Result:
Pop-up informing no network connection
No traceback on console
Please refer to attachment for traceback in rhsm.log

VERIFIED
Comment 7 errata-xmlrpc 2013-09-30 19:10:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.