Bug 969313 - AttributeError: 'dict' object has no attribute 'split'
AttributeError: 'dict' object has no attribute 'split'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:7861acbaf475a881f5c74ffdae6...
:
Depends On:
Blocks: 987978
  Show dependency treegraph
 
Reported: 2013-05-31 03:48 EDT by Marcus Moeller
Modified: 2014-01-30 17:06 EST (History)
25 users (show)

See Also:
Fixed In Version: anaconda-20.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 987978 (view as bug list)
Environment:
Last Closed: 2014-01-30 17:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (220.24 KB, text/plain)
2013-05-31 03:48 EDT, Marcus Moeller
no flags Details
File: anaconda.log (1.88 KB, text/plain)
2013-05-31 03:48 EDT, Marcus Moeller
no flags Details
File: backtrace (779 bytes, text/plain)
2013-05-31 03:48 EDT, Marcus Moeller
no flags Details
File: environ (760 bytes, text/plain)
2013-05-31 03:48 EDT, Marcus Moeller
no flags Details
File: ifcfg.log (492 bytes, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details
File: lsblk_output (1.45 KB, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details
File: nmcli_dev_list (28.20 KB, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details
File: packaging.log (412 bytes, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details
File: program.log (61.14 KB, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details
File: storage.log (56.55 KB, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details
File: syslog (125.29 KB, text/plain)
2013-05-31 03:49 EDT, Marcus Moeller
no flags Details

  None (edit)
Description Marcus Moeller 2013-05-31 03:48:36 EDT
Description of problem:
Tried to Start Fedora 19 Beta Anaconda from DVD
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 294, in nm_ntp_servers_from_dhcp
    for ip in options.unpack().split(" "):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 897, in _get_ntp_servers_from_dhcp
    ntp_servers = nm.nm_ntp_servers_from_dhcp()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 919, in wait_for_connecting_NM_thread
    _get_ntp_servers_from_dhcp(ksdata)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'dict' object has no attribute 'split'

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 919, in wait_for_connecting_NM_thread
    _get_ntp_servers_from_dhcp(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 897, in _get_ntp_servers_from_dhcp
    ntp_servers = nm.nm_ntp_servers_from_dhcp()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 294, in nm_ntp_servers_from_dhcp
    for ip in options.unpack().split(" "):
AttributeError: 'dict' object has no attribute 'split'
Comment 1 Marcus Moeller 2013-05-31 03:48:42 EDT
Created attachment 755182 [details]
File: anaconda-tb
Comment 2 Marcus Moeller 2013-05-31 03:48:46 EDT
Created attachment 755183 [details]
File: anaconda.log
Comment 3 Marcus Moeller 2013-05-31 03:48:50 EDT
Created attachment 755184 [details]
File: backtrace
Comment 4 Marcus Moeller 2013-05-31 03:48:54 EDT
Created attachment 755185 [details]
File: environ
Comment 5 Marcus Moeller 2013-05-31 03:49:00 EDT
Created attachment 755186 [details]
File: ifcfg.log
Comment 6 Marcus Moeller 2013-05-31 03:49:04 EDT
Created attachment 755187 [details]
File: lsblk_output
Comment 7 Marcus Moeller 2013-05-31 03:49:08 EDT
Created attachment 755188 [details]
File: nmcli_dev_list
Comment 8 Marcus Moeller 2013-05-31 03:49:14 EDT
Created attachment 755189 [details]
File: packaging.log
Comment 9 Marcus Moeller 2013-05-31 03:49:18 EDT
Created attachment 755190 [details]
File: program.log
Comment 10 Marcus Moeller 2013-05-31 03:49:22 EDT
Created attachment 755191 [details]
File: storage.log
Comment 11 Marcus Moeller 2013-05-31 03:49:26 EDT
Created attachment 755192 [details]
File: syslog
Comment 12 Sylvain Lapierre 2013-06-22 13:38:55 EDT
Description of problem:
boot on dvd fedora 19 beta mate compiz
setup wifi
install to hard disk

lon the hd a fedora 18 security spin is install
no other OS


Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-Compiz-x86_64-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 919, in wait_for_connecting_NM_thread
    _get_ntp_servers_from_dhcp(ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 897, in _get_ntp_servers_from_dhcp
    ntp_servers = nm.nm_ntp_servers_from_dhcp()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 294, in nm_ntp_servers_from_dhcp
    for ip in options.unpack().split(" "):
AttributeError: 'dict' object has no attribute 'split'
Comment 13 Sebastian Pölsterl 2013-07-02 14:36:28 EDT
Tried to start 'Install to Hard Drive'

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=6A57-F544 rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 14 Sylvain Lapierre 2013-07-02 21:32:53 EDT
dual boot system  win 7 x64 and security spin 18 x64

boot on cd
start install
setup wifi


cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Security-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 15 Stuart D Gathman 2013-07-02 22:24:27 EDT
Booted liveCD
Ran Compiz fusion Icon, spun the cube. 
Exited all windows, opened "Install to Disk"
Boom!

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-Compiz-i686-19- rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
other involved packages: python-libs-2.7.5-1.fc19.i686
package:        anaconda-19.30.13-1.fc19.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 16 Stuart D Gathman 2013-07-02 23:16:46 EDT
I see a variety of spins, and both CD and USB here.  So the trigger must be what is already on the disk.  Or else lots of people are downloading, attempting to install, and giving up in disgust.

In my case, there is already a Fedora 17 installation, with LVM and root and home LVs (and some additional LVs).
Comment 17 Sylvain Lapierre 2013-07-03 21:08:17 EDT
previous install aleredy crashed
previous OS is deft linux 8 beta X64 using grub

with Parted Magic delete partitions create new partition table
one boot ended with grub rescue mode

start fed 19 gnome x64
setup wifi
try install to disk

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 18 Stuart D Gathman 2013-07-03 21:43:33 EDT
BTW, this is on the release ISO - it is still broken. Don't ignore this because it was first reported on the Beta!
Comment 19 Stuart D Gathman 2013-07-04 10:25:17 EDT
nirik and some others looked at the backtrace and said that it had to do with network environment, not disk contents - indeed the crash is in nm.py.  He thought it was caused by dhcp6 on the network (and I do indeed run dhcp6).  
In any case, the workaround is simply to unplug the network cable and/or not connect the wireless.  I *may* try disabling dhcpd6.
Comment 20 Sylvain Lapierre 2013-07-04 17:26:07 EDT
this time on my first i didn't start the wifi, no wire cable an it works
Comment 21 Sylvain Lapierre 2013-07-05 06:24:34 EDT
Finally, I can install Fed 19 on 3 differents laptops simply by not connecting the wifi to my network. Previous installation on any of the 3 failed.
Comment 22 marcindulak 2013-07-08 07:20:07 EDT
(In reply to Stuart D Gathman from comment #19)
> nirik and some others looked at the backtrace and said that it had to do
> with network environment, not disk contents - indeed the crash is in nm.py. 
> He thought it was caused by dhcp6 on the network (and I do indeed run
> dhcp6).  
> In any case, the workaround is simply to unplug the network cable and/or not
> connect the wireless.  I *may* try disabling dhcpd6.

I confirm it has something to do with IPv6.
I'm installing using pxe/kickstart so unplugging the cable is not an option.
The --noipv6 kickstart option helps:
network --bootproto=dhcp --onboot yes --noipv6
Comment 23 jeremy rutman 2013-07-09 15:49:41 EDT
deleted exfat partition using gparted after booting from fedora install usb

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat rw rd.live.image rd.live.overlay=LABEL=LIVE quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 24 David Shea 2013-07-24 09:53:02 EDT
The problem was in the parsing of DHCP6 options for NTP server information. Since this feature is not currently implemented in NetworkManager or dhclient, it has been removed for now, fixing the crash.
Comment 25 Nels 2013-08-25 12:54:08 EDT
1. At opening screen after booting on Fed 19 install disk, choose Live System User;Settings;Network
2. Log onto local WiFi
3. Choose Activities;Install to hard drive icon
4. Receive error notification after about 3 seconds. No other information displayed.

On some occasions, install proceeds further (if I do not log onto WiFi)

Note: Master Boot Record had been destroyed by an earlier failed install of Fed. 19.  Could this be the problem?

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 26 Nels 2013-08-25 13:21:04 EDT
Disabled WiFi.  Install still failed, even after re-boot onto installation DVD.

Will try to re-constitute Win 7 MBR to see if that helps.
Comment 27 Jake Allison 2013-08-28 19:46:59 EDT
Well i click on install to hard drive for Fedora 19 Desktop Edition (Gnome) and it said error has occur.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 28 Georg Sauthoff 2013-09-05 15:42:37 EDT
I've booted the Fedora 19 Live KDE image (x86-64) from an SD-Card.

Then I've configured WLAN (dual stack mode, ipv4 + ipv6) and verified it via Konqueror.

After that I've clicked the 'Install to Hard Drive' icon on the desktop which has yielded a python stack trace which should be attached.

System: Thinkpad x200

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 29 Felix Kaechele 2013-10-04 10:39:52 EDT
Installing via Kickstart file

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOTIF=01-52:54:00:43:67:72 inst.ks=http://felix.fetzig.org/install/minimal.ks inst.repo=http://mirror.netcologne.de/fedora/linux/releases/19/Fedora/x86_64/os/
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Cannot get release name.
version:        19
Comment 30 Mario Lamas 2013-10-05 17:16:20 EDT
Execute the Fedora Installer.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=/ubninit root=live:UUID=DD67-43E8 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/ubnkern 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
other involved packages: python-libs-2.7.5-1.fc19.i686
package:        anaconda-19.30.13-1.fc19.i686
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 31 sammundo21 2013-11-14 22:19:24 EST
Trying to install Fedora 19 to my PC.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 32 Milovidov Mikhail 2013-12-03 07:54:12 EST
If I pluged network cable before anaconda started to load this error occured.

If I not pluged network cabel anaconda load succesfully and then I can plug network cabel again without of any errors.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=LIVE quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         AttributeError: 'dict' object has no attribute 'split'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19

Note You need to log in before you can comment on or make changes to this bug.