Bug 969368 - Management web application does not show property values with placeholders
Management web application does not show property values with placeholders
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity unspecified
: ER7
: EAP 6.1.1
Assigned To: Heiko Braun
:
: 969369 (view as bug list)
Depends On:
Blocks: 975403
  Show dependency treegraph
 
Reported: 2013-05-31 06:02 EDT by Christopher Grothe
Modified: 2013-10-21 10:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Users of previous versions of Red Hat JBoss Enterprise Application Platform 6 found that the Web Mangement Interface did not honor placeholder names the properties "new-connection-sql" and "connection-url" for a Datasource that contained placeholder properties. The issue was traced to an existing issue in the TextAreaItem used by the Ballroom widget library; the TextAreaItem did not support expressions. This support has been implemented in version 1.6.1 of the Ballroom component and has been included in this release of Red Hat JBoss Enterprise Application Platform.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1455 Major Resolved Management web application does not show property values with placeholders 2014-01-08 09:54:04 EST

  None (edit)
Description Christopher Grothe 2013-05-31 06:02:25 EDT
Description of problem:
The Management web application does not show the value of the properties
"new-connection-sql" 
and
"connection-url"
for a Datasource when the value contains placeholder properties.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. add a System Property
testString = "Hello World"
2a. set "new-connection-sql" = ${testString}
2b. set "connection-url" = ${testString}

Actual results:
Management web application shows no value

Expected results:
Management web application should show either the value with placeholder or the replaced value.

Additional info:
Comment 1 Heiko Braun 2013-06-05 04:32:31 EDT
*** Bug 969369 has been marked as a duplicate of this bug. ***
Comment 2 JBoss JIRA Server 2013-06-05 05:19:42 EDT
Heiko Braun <ike.braun@googlemail.com> made a comment on jira WFLY-1455

The problem is that TextAreaItem (ballroom component) doesn't support expressions yet.
Comment 3 JBoss JIRA Server 2013-06-05 05:33:56 EDT
Heiko Braun <ike.braun@googlemail.com> updated the status of jira WFLY-1455 to Resolved
Comment 4 JBoss JIRA Server 2013-06-05 05:33:56 EDT
Heiko Braun <ike.braun@googlemail.com> made a comment on jira WFLY-1455

Part of ballroom 1.6.1.FInal
Comment 5 Heiko Braun 2013-06-05 05:38:48 EDT
It's been a general issue: TextArea items did not support expressions so far. Thanks for cathing this.
Comment 6 Scott Mumford 2013-08-14 21:49:44 EDT
Added a draft Release Note. Please review for technical accuracy and comment if any problems are found.
Comment 8 Scott Mumford 2013-08-28 21:04:57 EDT
Marking for exclusion from the 6.1.1 Release Notes document as an entry for this bug could not be completed or verified in time.
Comment 9 Jakub Cechacek 2013-08-29 05:26:46 EDT
Verified 6.1.1.ER7

Note You need to log in before you can comment on or make changes to this bug.