Bug 969441 - User directory is not automatically created
User directory is not automatically created
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
: 969422 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 08:26 EDT by Lukas "krteknet" Novy
Modified: 2014-02-18 18:56 EST (History)
5 users (show)

See Also:
Fixed In Version: realmd-0.14.2-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 02:15:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhat: Add dependency on oddjobd (2.02 KB, patch)
2013-06-06 11:42 EDT, Stef Walter
no flags Details | Diff

  None (edit)
Description Lukas "krteknet" Novy 2013-05-31 08:26:52 EDT
Description of problem:
Following the testcase https://fedoraproject.org/wiki/QA:Testcase_realmd_login_any I'm able to login using AD account, but home directory is not created.

Version-Release number of selected component (if applicable):
realmd-0.14.2-1.fc19
oddjob-0.31.4-1.fc19 
oddjob-mkhomedir-0.31.4-1.fc19

How reproducible:
Always

Steps to Reproduce:
1. Join realm using realm join
2. Permit AD logins using realm permit --all
3. Login using ssh localhost

Actual results:
org.freedesktop.DBus.Error.ServiceUnknown: The name com.redhat.oddjob_mkhomedir was not provided by any .service files
Could not chdir to home directory ...: No such file or directory

Expected results:
Home is created

Additional info:
Comment 1 Patrik Kis 2013-05-31 09:13:27 EDT
This issue should be solved here:
bug 964971
bug 963722

It seems you are sunning the fixed versions of oddjob and realmd.
Can you check is oddjob is running when this issue is happening?
Comment 2 Lukas "krteknet" Novy 2013-05-31 09:26:13 EDT
Yes oddjobd is running.
Comment 3 Lukas "krteknet" Novy 2013-05-31 09:34:54 EDT
After reboot, home directory is created ok.
Comment 4 Lukas "krteknet" Novy 2013-05-31 09:39:04 EDT
Additional info:
I installed oddjob manually, joining&leaving domain befora&after, then installing oddjob-mkhomedir manually, joining&leaving domain after. Didn't helped. Restarting dbus service somewhat fuxored my system and I was unable to login using ssh after that, rebooting fixed everything.
Comment 5 Stef Walter 2013-06-06 11:42:21 EDT
Created attachment 757730 [details]
redhat: Add dependency on oddjobd
Comment 6 Fedora Update System 2013-06-06 12:17:44 EDT
realmd-0.14.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/realmd-0.14.2-2.fc19
Comment 7 Stef Walter 2013-06-06 12:30:34 EDT
*** Bug 969422 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-06-07 11:41:07 EDT
Package realmd-0.14.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing realmd-0.14.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10281/realmd-0.14.2-2.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-06-11 06:02:41 EDT
realmd-0.14.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/realmd-0.14.2-3.fc19
Comment 10 Fedora Update System 2013-06-18 02:15:02 EDT
realmd-0.14.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.