Bug 969491 - Please increase kernel.sched_migration_cost in virtual-host profile
Summary: Please increase kernel.sched_migration_cost in virtual-host profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tuned
Version: 6.4
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
: 960816 980893 (view as bug list)
Depends On:
Blocks: 996991 1013812
TreeView+ depends on / blocked
 
Reported: 2013-05-31 14:18 UTC by Julio Entrena Perez
Modified: 2021-06-04 08:45 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The kernel.sched_migration_cost tunable is kept on its default (0.5 ms). Consequence: Big virtualization hosts can experience high contention at the run queue lock. Fix: The kernel.sched_migration_cost tunable was increased 10 times in the virtual-host profile. Result: The added tuning eliminates the contention.
Clone Of:
: 986149 996991 1013812 (view as bug list)
Environment:
Last Closed: 2013-11-21 11:35:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed fix (849 bytes, patch)
2013-07-23 17:23 UTC, Jaroslav Škarvada
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 358033 0 None None None Never
Red Hat Product Errata RHBA-2013:1623 0 normal SHIPPED_LIVE tuned bug fix and enhancement update 2013-11-20 21:38:38 UTC

Description Julio Entrena Perez 2013-05-31 14:18:28 UTC
Description of problem:
Big virtualization hosts can experience high contention at the run queue lock, please see bug 960816 for more details.

Setting kernel.sched_migration_cost tunable to 5000000 (10X its default value) eliminates the contention.

Please add kernel.sched_migration_cost = 5000000 to "virtual-host" tuned profile.

Version-Release number of selected component (if applicable):
tuned-0.2.19-11.el6.1

How reproducible:
Always.

Steps to Reproduce:
1. Load a big virtualization host with a high number of busy VMs (e.g. host with 32 physical cores, 1TB of RAM running 60 VMs running JBoss).
2. Observe CPU usage, SSH into VMs.

Actual results:
- Unstable TSC warnings.
- High latency in VMs can be observed from a simple SSH session.
- "sleep 5" takes between 7 - 11 seconds to return.
- short softlockups.

Expected results:
VMs run smoothly.

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=960816
https://bugzilla.redhat.com/show_bug.cgi?id=825222

Comment 6 Andrew Cathrow 2013-07-22 14:50:25 UTC
*** Bug 980893 has been marked as a duplicate of this bug. ***

Comment 8 Jaroslav Škarvada 2013-07-23 17:23:50 UTC
Created attachment 777400 [details]
Proposed fix

Comment 12 Tomas Dosek 2013-11-11 16:03:18 UTC
*** Bug 1028987 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2013-11-21 11:35:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1623.html

Comment 14 Rik van Riel 2014-03-20 19:01:06 UTC
*** Bug 960816 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.