Bug 969591 - on F19 alpha AND beta Pysol hangs on startup
on F19 alpha AND beta Pysol hangs on startup
Status: CLOSED DUPLICATE of bug 995783
Product: Fedora
Classification: Fedora
Component: PySolFC (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
: 981077 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 16:41 EDT by fred smith
Modified: 2016-01-31 20:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 11:49:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes engine 'tile' issue on latest tk 8.5 package (888 bytes, patch)
2013-07-09 10:16 EDT, Alexey Radkov
no flags Details | Diff

  None (edit)
Description fred smith 2013-05-31 16:41:46 EDT
Description of problem:
Pysol does not complete initialization, the startup progress bar hangs about 90% of the way across. ^C does not kill it, must kill from commandline.

if started from commandline, it emits these error messages to its terminal window:
$ /usr/bin/python /usr/share/PySolFC/pysol.py
*** Error in `/usr/bin/python': malloc(): memory corruption: 0x00000000044b0b60 ***
*** Error in `/usr/bin/python': malloc(): memory corruption: 0x00000000044b0b60 ***



Version-Release number of selected component (if applicable):
PySolFC-2.0-8.fc19.noarch


How reproducible:
always


Steps to Reproduce:
1.start Pysol either from the games menu, or from commandline
2.watch.
3.

Actual results:
failure


Expected results:
solitaire! :)

Additional info:
Comment 1 Alexey Radkov 2013-07-05 15:43:57 EDT
pysol --tk

fixes this. There is something wrong with backend 'tile' which is set automatically in settings.py
Comment 2 fred smith 2013-07-05 20:45:43 EDT
Ah. thanks.

As I've already found out, the PySol-FC from sourceforge work fine, too, so I uninstalled the RPM and installed that. (http://pysolfc.sourceforge.net/)
Comment 3 Stewart Adam 2013-07-06 13:26:36 EDT
An update on this: I no longer have the time to properly maintain this module and I will likely only be able to install F19 for testing in two weeks... Sorry.

I have announced an offer for other maintainers to take up this module, and if someone is interested they will be able to repackage a new release. In the mean time, please use the --tk workaround provided in comment #1.
Comment 4 Stewart Adam 2013-07-06 13:28:07 EDT
*** Bug 981077 has been marked as a duplicate of this bug. ***
Comment 5 KitchM 2013-07-07 15:29:36 EDT
That addition of "--tk" to the command line worked for me.

Thanks.
Comment 6 Alexey Radkov 2013-07-09 10:16:13 EDT
Created attachment 771051 [details]
fixes engine 'tile' issue on latest tk 8.5 package

Currently pysol checks if 'tile' should be loaded in line

root.tk.eval('package require tile 0.7.8')

in init.py. This raises an exception if 'tile' is not present in the system but does not actually raise if Tk is 8.5.0 and bigger (it evals to '0.8.6' instead). However in Tk 8.5 'tile' should not be loaded. See how it's normally checked here: http://nullege.com/codes/search/Tkinter.Tk.tk.eval. There is the pysol example there as well and it differs from others. Attached patch is a hybrid solution: it still checks for exception but does it only if variable tkversion < '0.8.5' which prevents loading tile in Tk 8.5.
Comment 7 Fedora Admin XMLRPC Client 2013-08-05 13:35:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 KitchM 2013-08-05 15:18:20 EDT
Thanks for the work on this.
Comment 9 Jaromír Cápík 2013-09-19 11:49:56 EDT
Hello guys. 

This one should be fixed with the latest python-pillow.
Closing ... feel free to reopen if the issue persists.

Regards,
Jaromir.

*** This bug has been marked as a duplicate of bug 995783 ***
Comment 10 KitchM 2013-09-19 17:38:32 EDT
Thanks much.  I'll look for the update to come thru on Yumex.

Note You need to log in before you can comment on or make changes to this bug.