Bug 969608 - [kn_IN][mr_IN][fr_FR][as_IN] missing usage translations for rhsmcertd tool
[kn_IN][mr_IN][fr_FR][as_IN] missing usage translations for rhsmcertd tool
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-31 18:26 EDT by John Sefler
Modified: 2013-07-17 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 13:32:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-05-31 18:26:09 EDT
Description of problem:
I don't believe the source of this problem is in component subscription-manager, but it is visible by subscription-manager and it only happens in RHEL5.  I believe the problem is in one of the libraries that the rhsmcertd tool depends on.

These four languages appear to be missing translations as demonstrated below when using the rhsmcertd tool

[kn_IN]
[mr_IN]
[fr_FR]
[as_IN] 


Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.8.9-1.git.0.3aae03b.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-5 ~]# LANG=kn_IN.utf8 rhsmcertd -?
Usage:                       <================ EXPECTED A TRANSLATION
  rhsmcertd [OPTION...]      <================ EXPECTED A TRANSLATION

Help Options:                <================ EXPECTED A TRANSLATION
  -?, --help                             Show help options  <==== EXPECTED A TRANSLATION

Application Options:         <================ EXPECTED A TRANSLATION
  --cert-interval=MINUTES                ಅಪ್ರಚಲಿತಗೊಳಿಸಲಾಗಿದೆ, --cert-check-interval ಅನ್ನು ನೋಡಿ
  -c, --cert-check-interval=MINUTES      ಪ್ರಮಾಣಪತ್ರ ಪರಿಶೀಲನೆಯನ್ನು ಚಲಾಯಿಸಬೇಕಿರುವ ಅಂತರ (ನಿಮಿಷಗಳಲ್ಲಿ)
  --heal-interval=MINUTES                ಅಪ್ರಚಲಿತಗೊಳಿಸಲಾಗಿದೆ, --auto-attach-interval ಅನ್ನು ನೋಡಿ
  -i, --auto-attach-interval=MINUTES     auto-attach ಅನ್ನು ಚಲಾಯಿಸಲು ಕಾಲಾವಧಿ (ನಿಮಿಷಗಳಲ್ಲಿ)
  -n, --now                              ಯಾವುದೆ ವಿಳಂಬವಿಲ್ಲದೆ ಆರಂಭಿಕ ಪರಿಶೀಲನೆಗಳನ್ನು ಕೂಡಲೇ ಚಲಾಯಿಸು
  -d, --debug                            ದೋಷನಿವಾರಣ ಮಾಹಿತಿಯನ್ನು ತೋರಿಸು

[root@jsefler-5 ~]# LANG=mr_IN.utf8 rhsmcertd -?
Usage:                       <================ EXPECTED A TRANSLATION
  rhsmcertd [OPTION...]      <================ EXPECTED A TRANSLATION

Help Options:                <================ EXPECTED A TRANSLATION
  -?, --help                             Show help options  <==== EXPECTED A TRANSLATION

Application Options:         <================ EXPECTED A TRANSLATION
  --cert-interval=MINUTES                वापर नाही, --cert-check-interval पहा
  -c, --cert-check-interval=MINUTES      सर्ट तपासणी चालवण्याकरिता कालावधी (मिनीटात)
  --heal-interval=MINUTES                वापर नाही, --auto-attach-interval पहा
  -i, --auto-attach-interval=MINUTES     auto-attach (मिनीटात) चालवण्यासाठी अवधी
  -n, --now                              सुरूवातीची चाचणी पटकलन चालवा, विना विलंब
  -d, --debug                            डिबग संदेश दाखवा

[root@jsefler-5 ~]# LANG=as_IN.utf8 rhsmcertd -?
Usage:                       <================ EXPECTED A TRANSLATION
  rhsmcertd [OPTION...]      <================ EXPECTED A TRANSLATION

Help Options:                <================ EXPECTED A TRANSLATION
  -?, --help                             Show help options  <==== EXPECTED A TRANSLATION

Application Options:         <================ EXPECTED A TRANSLATION
  --cert-interval=MINUTES                স্খলিত, --cert-check-interval চাওক
  -c, --cert-check-interval=MINUTES      cert নীৰিক্ষণ চলোৱাৰ অন্তৰাল (মিনিটত)
  --heal-interval=MINUTES                স্খলিত, --auto-attach-interval চাওক
  -i, --auto-attach-interval=MINUTES     স্ব-সংলগ্ন কাৰ্য্য চলোৱাৰ অন্তৰাল (মিনিটত)
  -n, --now                              আৰম্ভণি নীৰিক্ষণসমূহ তৎক্ষনাত চলাওক, কোনো বিলম্ব নকৰাকৈ
  -d, --debug                            ডিবাগ বাৰ্তসমূহ দেখুৱাওক

[root@jsefler-5 ~]# LANG=fr_FR.utf8 rhsmcertd -?
Usage :                       <================ EXPECTED A TRANSLATION
  rhsmcertd [OPTION...]       <================ EXPECTED A TRANSLATION

Options de l'aide :
  -?, --help                             Afficher les options de l'aide

Options de l'application :
  --cert-interval=MINUTES                déprécié, voir --cert-check-interval
  -c, --cert-check-interval=MINUTES      intervalle d'exécution des vérifications de certificats ( en minutes)
  --heal-interval=MINUTES                déprécié, voir --auto-attach-interval
  -i, --auto-attach-interval=MINUTES     intervalle d'exécution d'auto-attach (en minutes)
  -n, --now                              exécuter les vérifications initiales immédiatement, sans aucun délai
  -d, --debug                            afficher les messages de débogage




Additional Info:

Notice that these offending strings are translated in other languages like ja_JP
[root@jsefler-5 ~]# LANG=ja_JP.utf8 rhsmcertd -?
用法:
  rhsmcertd [オプション...] 

ヘルプのオプション:
  -?, --help                             ヘルプのオプションを表示する

アプリケーションのオプション:
  --cert-interval=MINUTES                廃止予定、 --cert-check-interval を参照
  -c, --cert-check-interval=MINUTES      証明書チェックを実行する間隔 (分単位)
  --heal-interval=MINUTES                廃止予定、 --auto-attach-interval を参照
  -i, --auto-attach-interval=MINUTES     自動割り当てを実行する間隔 (分単位)
  -n, --now                              初期チェックを遅延なしで直ちに実行
  -d, --debug                            デバッグメッセージの表示
Comment 1 RHEL Product and Program Management 2013-05-31 18:59:32 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Devan Goodwin 2013-07-15 10:19:02 EDT
Moving translation bugs to ON_QA, zanata indicates translations are now 100%. Please forgive us if any of these turn up to have been missed and flip back to NEW.
Comment 3 Sharath Dwaral 2013-07-16 17:17:52 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.8.13-1.el5
subscription-manager-1.8.13-1.el5
subscription-manager-gui-1.8.13-1.el5
python-rhsm-1.8.13-1.el5_9
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-firstboot-1.8.13-1.el5

Verification

>> Locale: fr_FR    TRANSLATED

# LANG=fr_FR.UTF-8 rhsmcertd -?
Usage :
  rhsmcertd [OPTION...] 

Options de l'aide :
  -?, --help                             Afficher les options de l'aide

Options de l'application :
  --cert-interval=MINUTES                déprécié, voir --cert-check-interval
  -c, --cert-check-interval=MINUTES      intervalle d'exécution des vérifications de certificats ( en minutes)
  --heal-interval=MINUTES                déprécié, voir --auto-attach-interval
  -i, --auto-attach-interval=MINUTES     intervalle d'exécution d'auto-attach (en minutes)
  -n, --now                              exécuter les vérifications initiales immédiatement, sans aucun délai
  -d, --debug                            afficher les messages de débogage


>> LOCALE: as_IN  kn_IN mr_IN  NOT TRANSLATED

Moving to NEW


Additional Information:

# LANG=kn_IN.UTF-8 rhsmcertd -?
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -?, --help                             Show help options

Application Options:
  --cert-interval=MINUTES                ಅಪ್ರಚಲಿತಗೊಳಿಸಲಾಗಿದೆ, --cert-check-interval ಅನ್ನು ನೋಡಿ
  -c, --cert-check-interval=MINUTES      ಪ್ರಮಾಣಪತ್ರ ಪರಿಶೀಲನೆಯನ್ನು ಚಲಾಯಿಸಬೇಕಿರುವ ಅಂತರ (ನಿಮಿಷಗಳಲ್ಲಿ)
  --heal-interval=MINUTES                ಅಪ್ರಚಲಿತಗೊಳಿಸಲಾಗಿದೆ, --auto-attach-interval ಅನ್ನು ನೋಡಿ
  -i, --auto-attach-interval=MINUTES     auto-attach ಅನ್ನು ಚಲಾಯಿಸಲು ಕಾಲಾವಧಿ (ನಿಮಿಷಗಳಲ್ಲಿ)
  -n, --now                              ಯಾವುದೆ ವಿಳಂಬವಿಲ್ಲದೆ ಆರಂಭಿಕ ಪರಿಶೀಲನೆಗಳನ್ನು ಕೂಡಲೇ ಚಲಾಯಿಸು
  -d, --debug                            ದೋಷನಿವಾರಣ ಮಾಹಿತಿಯನ್ನು ತೋರಿಸು


# LANG=mr_IN.UTF-8 rhsmcertd -?
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -?, --help                             Show help options

Application Options:
  --cert-interval=MINUTES                वापर नाही, --cert-check-interval पहा
  -c, --cert-check-interval=MINUTES      सर्ट तपासणी चालवण्याकरिता कालावधी (मिनीटात)
  --heal-interval=MINUTES                वापर नाही, --auto-attach-interval पहा
  -i, --auto-attach-interval=MINUTES     auto-attach (मिनीटात) चालवण्यासाठी अवधी
  -n, --now                              सुरूवातीची चाचणी पटकलन चालवा, विना विलंब
  -d, --debug                            डिबग संदेश दाखवा


# LANG=as_IN.UTF-8 rhsmcertd -?
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -?, --help                             Show help options

Application Options:
  --cert-interval=MINUTES                স্খলিত, --cert-check-interval চাওক
  -c, --cert-check-interval=MINUTES      cert নীৰিক্ষণ চলোৱাৰ অন্তৰাল (মিনিটত)
  --heal-interval=MINUTES                স্খলিত, --auto-attach-interval চাওক
  -i, --auto-attach-interval=MINUTES     স্ব-সংলগ্ন কাৰ্য্য চলোৱাৰ অন্তৰাল (মিনিটত)
  -n, --now                              আৰম্ভণি নীৰিক্ষণসমূহ তৎক্ষনাত চলাওক, কোনো বিলম্ব নকৰাকৈ
  -d, --debug                            ডিবাগ বাৰ্তসমূহ দেখুৱাওক
Comment 4 Bryan Kearney 2013-07-17 13:32:49 EDT
Correct, this one is due to issues in the underlieing library. I am moving to CLOSE/WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.