Bug 969676 - types.py:113: Warning: invalid (NULL) pointer instance return info.invoke(*args, **kwargs)
types.py:113: Warning: invalid (NULL) pointer instance return info.invoke(*...
Status: CLOSED DUPLICATE of bug 679486
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 14:50 EDT by Michael Catanzaro
Modified: 2013-06-05 00:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 00:43:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.03 KB, text/x-log)
2013-06-01 14:50 EDT, Michael Catanzaro
no flags Details
anaconda 19.30-1 exception report (366.84 KB, text/plain)
2013-06-01 14:54 EDT, Michael Catanzaro
no flags Details

  None (edit)
Description Michael Catanzaro 2013-06-01 14:50:52 EDT
Created attachment 755606 [details]
anaconda.log

Description of problem: I cannot install Fedora 19 Beta (using the default GNOME live CD). When I click "install now," no window opens for anaconda, but the anaconda process starts and begins to eat away my CPU.

When run as root in a terminal, there are tons of errors:

Starting installer, one moment...
anaconda 19.30-1 for anaconda bluesky (pre-release) started.
No protocol specified

** (anaconda:2720): WARNING **: Could not open X display
No protocol specified
No protocol specified

(anaconda:2720): Gdk-CRITICAL **: gdk_screen_get_root_window: assertion `GDK_IS_SCREEN (screen)' failed
No protocol specified
An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details

<related warnings, massive snip>

(anaconda:2720): Gtk-CRITICAL **: _gtk_css_rgba_value_get_rgba: assertion `rgba->class == &GTK_CSS_VALUE_RGBA' failed
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-bluesky&arch=x86_64 error was 
No repomd file
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=updates-testing-fbluesky&arch=x86_64 error was 
No repomd file
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=updates-released-fbluesky&arch=x86_64 error was 
No repomd file
^C

Probably more helpful errors are in anaconda.log (attached). Note that I ran (and killed) anaconda three times.

Version-Release number of selected component (if applicable): 19.30-1.fc19


How reproducible: Always


Steps to Reproduce:
1. Run anaconda :(

Actual results: No window opens and anaconda process uses large amount of CPU


Expected results: anaconda opens


Additional info:
Comment 1 Michael Catanzaro 2013-06-01 14:54:33 EDT
Created attachment 755607 [details]
anaconda 19.30-1 exception report
Comment 2 Michael Catanzaro 2013-06-04 23:06:40 EDT
Probably a blocker under release criteria "The installer must run when launched normally from the release-blocking images."
Comment 3 Adam Williamson 2013-06-04 23:21:48 EDT
You don't run 'anaconda' directly if you want to run it from a console on a live image, you run 'liveinst'.

I'm going to take a guess that this is likely https://bugzilla.redhat.com/show_bug.cgi?id=679486 . Can you check if that matches up?
Comment 4 Michael Catanzaro 2013-06-05 00:43:33 EDT
I'll look more at this tomorrow, but as the stack trace in my exception report is so similar to the one in Bug #928279, it's clearly the same bug. Thanks.

*** This bug has been marked as a duplicate of bug 679486 ***

Note You need to log in before you can comment on or make changes to this bug.