Bug 969684 - BootLoaderError: bootloader install failed
BootLoaderError: bootloader install failed
Status: CLOSED DUPLICATE of bug 986431
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:a9f66ba3a71dd8ca85917188fe0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 15:49 EDT by Giridharan GM
Modified: 2013-09-03 11:44 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 11:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1017.37 KB, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: anaconda.log (88.42 KB, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: backtrace (854 bytes, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: environ (863 bytes, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: ifcfg.log (919 bytes, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: lsblk_output (2.84 KB, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: messages (305.55 KB, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: nmcli_dev_list (5.01 KB, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: packaging.log (402 bytes, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: program.log (110.16 KB, text/plain)
2013-06-01 15:50 EDT, Giridharan GM
no flags Details
File: storage.log (503.44 KB, text/plain)
2013-06-01 15:51 EDT, Giridharan GM
no flags Details
anaconda-tb-OzlJGj (416.74 KB, text/plain)
2013-06-26 03:55 EDT, Steve Tyler
no flags Details
anaconda-tb-jdh2cS (1.35 MB, text/plain)
2013-08-13 04:54 EDT, Steve Tyler
no flags Details
Comment (460.40 KB, text/plain)
2013-06-04 18:07 EDT, Stephane BOUNET
no flags Details

  None (edit)
Description Giridharan GM 2013-06-01 15:49:27 EDT
Description of problem:
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
BootLoaderError: bootloader install failed

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=/isolinux/initrd0.img root=live:UUID=A4B2-90AD rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/isolinux/vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
BootLoaderError: bootloader install failed

Potential duplicate: bug 924902
Comment 1 Giridharan GM 2013-06-01 15:50:00 EDT
Created attachment 755633 [details]
File: anaconda-tb
Comment 2 Giridharan GM 2013-06-01 15:50:07 EDT
Created attachment 755634 [details]
File: anaconda.log
Comment 3 Giridharan GM 2013-06-01 15:50:11 EDT
Created attachment 755635 [details]
File: backtrace
Comment 4 Giridharan GM 2013-06-01 15:50:15 EDT
Created attachment 755636 [details]
File: environ
Comment 5 Giridharan GM 2013-06-01 15:50:20 EDT
Created attachment 755637 [details]
File: ifcfg.log
Comment 6 Giridharan GM 2013-06-01 15:50:25 EDT
Created attachment 755638 [details]
File: lsblk_output
Comment 7 Giridharan GM 2013-06-01 15:50:37 EDT
Created attachment 755639 [details]
File: messages
Comment 8 Giridharan GM 2013-06-01 15:50:42 EDT
Created attachment 755640 [details]
File: nmcli_dev_list
Comment 9 Giridharan GM 2013-06-01 15:50:47 EDT
Created attachment 755641 [details]
File: packaging.log
Comment 10 Giridharan GM 2013-06-01 15:50:55 EDT
Created attachment 755642 [details]
File: program.log
Comment 11 Giridharan GM 2013-06-01 15:51:21 EDT
Created attachment 755643 [details]
File: storage.log
Comment 12 Reartes Guillermo 2013-06-01 18:18:56 EDT
In program.log this shows up:

00:57:47,422 INFO program: /usr/sbin/grub2-bios-setup: warning: this LDM has no Embedding Partition; embedding won't be possible.
00:57:47,422 INFO program: /usr/sbin/grub2-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
00:57:47,423 INFO program: /usr/sbin/grub2-bios-setup: error: will not proceed with blocklists.

did you use windows LDM at some point?
Comment 13 Giridharan GM 2013-06-01 20:10:05 EDT
earlier, i had used windows. but later then i installed ubuntu 12.04. not a dual boot. in both these installations, i've a 400GB partition[ntfs] left untouched(data)
Comment 14 Chris Murphy 2013-06-01 22:52:34 EDT
LDM isn't supported by GRUB2 so you'll need to remove the offending entry from the MBR if you want to use GRUB.
Comment 15 Giridharan GM 2013-06-02 22:03:49 EDT
(In reply to Chris Murphy from comment #14)
> LDM isn't supported by GRUB2 so you'll need to remove the offending entry
> from the MBR if you want to use GRUB.

i've erased the entire disk, and executed automatic partitioning scheme. Now everything works. Is it possible to keep a ntfs partition in fedora?
Comment 16 Chris Murphy 2013-06-02 23:57:23 EDT
(In reply to Giridharan GM from comment #15)
>Is it possible to keep a ntfs partition in fedora?


Yes. Just make an extended partition if it doesn't have to be a bootable NTFS volume, and format it NTFS. MBR and GPT are supported by GRUB, but the LDM scheme isn't. The problem wasn't an issue with NTFS.
Comment 17 Giridharan GM 2013-06-03 00:03:30 EDT
(In reply to Chris Murphy from comment #16)
> (In reply to Giridharan GM from comment #15)
> >Is it possible to keep a ntfs partition in fedora?
> 
> 
> Yes. Just make an extended partition if it doesn't have to be a bootable
> NTFS volume, and format it NTFS. MBR and GPT are supported by GRUB, but the
> LDM scheme isn't. The problem wasn't an issue with NTFS.

well that didn't worked..using gparted, i used GPT and created extended partition. still, while installing bootloader, same error appeared. That's y I opted for automated partition. now the /home is of 400GB size.
Comment 18 Jairo Leiva 2013-06-03 04:13:49 EDT
Description of problem:
I  have installed Windows 7 from time inmemorial. Now  I tried to install Fedora 18 but the installation failed Bootloaer install failed it says then  I tried again this time Fedora 19-beta  same error! BOOTLOADER INSTALL FAILED.
I tried  install from usb 4g.

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=vfat ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-libs-2.7.4-4.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
BootLoaderError: bootloader install failed
Comment 19 Chris Murphy 2013-06-03 09:55:40 EDT
(In reply to Jairo Leiva from comment #18)
Can you attach anaconda, program and storage logs, and the anaconda-tb- file from /var/log/anaconda/. thanks.
Comment 20 Giridharan GM 2013-06-03 11:50:21 EDT
(In reply to Chris Murphy from comment #16)
> (In reply to Giridharan GM from comment #15)
> >Is it possible to keep a ntfs partition in fedora?
> 
> 
> Yes. Just make an extended partition if it doesn't have to be a bootable
> NTFS volume, and format it NTFS. MBR and GPT are supported by GRUB, but the
> LDM scheme isn't. The problem wasn't an issue with NTFS.

Chris, can u help me with partitioning? I want 2 partitions. 100 GB for Fedora and the rest 400GB for data purposes. 
so,
1. GPT or msdos partition table?
2. what are the necessary partitions(primary/extended) i need to create, and specify its size etc

Help...
Comment 21 Chris Murphy 2013-06-03 12:47:26 EDT
Using gparted, use MBR, 1 partition the whole disk as NTFS. Then run the Fedora installer and through guided partitioning (reclaim space) shrink the NTFS partition to the size you want it, and Fedora will be installed in the rest of the space. No matter what Fedora needs more than 1 partition so a 2 partition layout isn't going to work. I'd just like the guided path figure it out after you tell it how much to shrink the NTFS volume.
Comment 22 Reartes Guillermo 2013-06-04 10:03:39 EDT
Description of problem:
i installed to a md raid1 /boot and / (vda,vdb)
both disks are gpt, vda1 is a biosboot partition.

vdb1 was a biosboot partition, but since anaconda overwrites it (i am workarounding other issue) i decided 
to 'protect it' by changing its guid. So it is not a biosboot partition but a be02 (solaris boot) partition.

it was not expected that grub2 tired to install to such partition since it is not a biosboot partition. 
and of course.

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
BootLoaderError: bootloader install failed
Comment 23 Reartes Guillermo 2013-06-04 12:29:06 EDT
@Jairo Leiva 

Please also attach program.log

My issue (comment #22 is different from the reported in the description).
Vdb1 was not marked for 'reformat' neither an explicit bootloader target
in 'Full Disk Summary and Bootloader' and it was not even a biosboot, since
i changed its guid before.

10:53:06,622 INFO program: Running... grub2-install --no-floppy /dev/vda
10:53:09,829 INFO program: Installation finished. No error reported.
10:53:09,836 DEBUG program: Return code: 0
10:53:09,837 INFO program: Running... grub2-install --no-floppy /dev/vdb
10:53:14,116 INFO program: /usr/sbin/grub2-bios-setup: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
10:53:14,123 INFO program: /usr/sbin/grub2-bios-setup: error: embedding is not possible, but this is required for RAID and LVM install.
10:53:14,125 DEBUG program: Return code: 1

It appears that all different bootloader installation failures are put in this bug-report.
Comment 24 Ladislav Jozsa 2013-06-04 13:22:03 EDT
Description of problem:
In the end of the installation when booloader was about to be installed this error has occured.

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
BootLoaderError: bootloader install failed
Comment 25 Chris Murphy 2013-06-04 13:28:37 EDT
(In reply to Ladislav Jozsa from comment #24)
Could you please post /tmp/*.logs or /var/log/anaconda/*.logs
Comment 26 Stephane BOUNET 2013-06-04 16:45:49 EDT
Description of problem:
Grub2 cannot be installed wherreas grub 0.97 had no probleme for the same spec.
I had the same issue with fedora 17 and 18 but with them grub2 was installing but not working.
This time it doesn't install at all and stop te install process.
I've try to install grub2 manualy and it complains about not being able to see /boot/grub2/ at boot time.
I have a raid 01 with nvidia array Mainboard L1N64-SLI WS/B 

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
BootLoaderError: bootloader install failed
Comment 27 Chris Murphy 2013-06-04 16:51:34 EDT
(In reply to Stephane BOUNET from comment #26)
Could you please post program.log and storage.log from one of the #c25 locations.
Comment 28 Stephane BOUNET 2013-06-04 18:07:27 EDT
Created attachment 915722 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 29 Chris Murphy 2013-06-04 21:49:15 EDT
(In reply to Stephane BOUNET from comment #28)
Wow. I realize I wrote "post it" instead of "attach it" but it seems like a self-evidently bad idea to have pasted almost 9000 lines of a log file instead of attaching the log as a file. Jeez.

It looks like grub2-install is being run on a DMRAID device named /dev/mapper/nvidia_cafidbca1 rather than the physical drive(s) that make it up.

> 21:47:18,622 INFO program: Running... grub2-install --no-floppy
> /dev/mapper/nvidia_cafidbca
> 21:47:20,996 INFO program: /usr/sbin/grub2-probe: error: cannot find a GRUB
> drive for /dev/mapper/nvidia_cafidbca.  Check your device.map.
Comment 30 Ladislav Jozsa 2013-06-05 04:20:19 EDT
(In reply to Chris Murphy from comment #25)
> (In reply to Ladislav Jozsa from comment #24)
> Could you please post /tmp/*.logs or /var/log/anaconda/*.logs

I'll try to reproduce it in the evening once more and post logs manually. I tried to install F19 on RAID5 array, /boot partition was also placed on RAID5.
Comment 31 Chris Murphy 2013-06-05 11:28:05 EDT
Please *attach* logs so there isn't another comment 28. When you reply, state the kind of raid and how it was configured (if md raid, did anaconda set up the raid; if hardware raid, what vendor).
Comment 32 Netbulae 2013-06-19 08:41:36 EDT
Description of problem:
Installing F19 Beta1 Netinstall on Samsung 830 SSD

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2339, in writeBootLoader
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1554, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1540, in install
    raise BootLoaderError("bootloader install failed")
BootLoaderError: bootloader install failed
Comment 33 Peter Kotvan 2013-06-20 06:52:26 EDT
Performed ISCSI installation with /boot partition on local disc and / on iscsi. No other changes were made to default installation confguration. During the installation anaconda failed to install bootloader.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-TC6\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.9-1
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Cannot get release name.
version:        19-TC6
Comment 34 Netbulae 2013-06-20 08:53:01 EDT
additional info:
The SSD I used had been in a hw raid array but I overwrote it with /dev/zero and created a new msdos partition table with gparted.
Comment 35 Chris Murphy 2013-06-20 14:06:35 EDT
(In reply to Peter Kotvan from comment #33)
(In reply to Netbulae from comment #34)

Can you both please attach program.log and anaconda-tb? The cause of failure is unclear.
Comment 36 Netbulae 2013-06-21 04:39:48 EDT
Hi,

The logs are not stored on the SSD it appears. I'll have to install again, but it will probably be somewhere next week before I have time to do this.
Comment 37 Peter Kotvan 2013-06-21 04:45:38 EDT
I've tried to reproduce the error two times with no success. I'll try it again later.
Comment 38 Steve Tyler 2013-06-26 03:34:46 EDT
Attempting to reproduce Bug 969709 in a VM.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.11-1.fc19.x86_64
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 39 Steve Tyler 2013-06-26 03:55:02 EDT
Created attachment 765441 [details]
anaconda-tb-OzlJGj

anaconda log file corresponding to Comment 38.
Reproducer was to attempt to install to a disk image having a 1GB NTFS primary partition starting at sector 1.
parted was used to pre-partition the disk image.
mkntfs was used to format the partition.

See Bug 969709.

[liveuser@localhost tmp]$ sudo parted /dev/sdb p free
Model: ATA QEMU HARDDISK (scsi)
Disk /dev/sdb: 12.9GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
        0.00B   511B    512B             Free Space
 1      512B    1074MB  1074MB  primary  ntfs
        1074MB  1075MB  1048kB           Free Space
 2      1075MB  1599MB  524MB   primary  ext4         boot
 3      1599MB  12.9GB  11.3GB  primary               lvm
Comment 40 Chris Murphy 2013-06-27 11:50:27 EDT
Install to a disk without an MBR gap, but otherwise has enough space for installation.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.11-1.fc19.x86_64
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 41 Chris Murphy 2013-06-27 12:11:33 EDT
(In reply to Steve Tyler from comment #39)
Effectively bug 969709 is a specific way of triggering the crash in this bug 969684. There are multiple causes triggering this crash.

The (arguably blocking) bug here is that anaconda crashes: beta criterion "Reject or disallow invalid disk and volume configurations without crashing."

Of course it'd be nice if anaconda could prequalify the target disk in advance, but the lack of an MBR gap is sufficiently rare that I'm not sure it's worth the effort. The use of LDM however, might be a different story, I've never seen a default installation of Windows use LDM but I think I read in a user forum that an OEM installation was leveraging it.
Comment 42 Mark Cochran 2013-07-03 18:02:05 EDT
F19 ananconda installer error during "Installing Bootloader step".  Dual-boot install with F18 on separate LVM, using existing 1GB ext4 file system for /boot.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Cannot get release name.
version:        19
Comment 43 Germano Massullo 2013-07-04 05:26:21 EDT
Could my bugreport https://bugzilla.redhat.com/show_bug.cgi?id=979805 be related to this one?
Comment 44 William Mihalo 2013-07-05 12:57:03 EDT
Bootloader write failed. Created a bootloader for RAID1 environment--newly formatted disks.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 45 tim.moor 2013-08-06 22:23:56 EDT
Whlie performing an fresh install of FC19 the following error was encountered. 

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Cannot get release name.
version:        19
Comment 46 Steve Tyler 2013-08-07 02:16:00 EDT
(In reply to tim.moor from comment #45)
...
> reason:         BootLoaderError: bootloader install failed
...

Thanks for your report. That exception string is, unfortunately, so generic that it could mean several things. If you can reproduce, could you attach anaconda-tb-* from /tmp in the install environment?
Comment 47 David Allen 2013-08-11 19:58:25 EDT
I am not surprised. I was not even asked where I wanted the bootloader. If the installer was really smart, it might have looked at the existing Grub and its settings. But since it had already messed up my installation, I guess it couldn't do that.

What happened? I don't know, It apparently got through installing packages and then barfed.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20i386 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
package:        anaconda-19.30.13-1
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Cannot get release name.
version:        19
Comment 48 Steve Tyler 2013-08-13 04:47:54 EDT
Attempt to reproduce Bug 995892.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         BootLoaderError: bootloader install failed
release:        Cannot get release name.
version:        19
Comment 49 Steve Tyler 2013-08-13 04:54:27 EDT
Created attachment 786079 [details]
anaconda-tb-jdh2cS

(In reply to Steve Tyler from comment #48)
> Attempt to reproduce Bug 995892.
> 
> cmdline:        /usr/bin/python  /sbin/anaconda
> cmdline_file:   initrd=initrd.img
> inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
> hashmarkername: anaconda
> kernel:         3.9.5-301.fc19.x86_64
> package:        anaconda-19.30.13-1
> product:        Fedora
> reason:         BootLoaderError: bootloader install failed
> release:        Cannot get release name.
> version:        19
Comment 50 Steve Tyler 2013-08-13 05:26:33 EDT
(In reply to Steve Tyler from comment #49)
> Created attachment 786079 [details]
> anaconda-tb-jdh2cS

The installer allows installation to begin with a 70 MiB /boot partition (sda2):
>>> 143360.0*512/1024**2
70.0

That is about the size of the /boot partition reported in Bug 995892:
>>> 74027520.0/1024**2
70.59814453125

Snippet from attached anaconda-tb-jdh2cS:
...
03:40:58,722 INFO program: Running... grub2-install --no-floppy /dev/sda
03:41:01,791 INFO program: cp: error writing '/boot/grub2/fonts/unicode.pf2': No space left on device
03:41:01,794 INFO program: cp: failed to extend '/boot/grub2/fonts/unicode.pf2': No space left on device
03:41:01,796 DEBUG program: Return code: 1
...

$ cat parted-usp-free-sda-2.txt 
Model: ATA QEMU HARDDISK (scsi)
Disk /dev/sda: 67108864s
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start      End        Size       Type      File system  Flags
        63s        2047s      1985s                Free Space
 1      2048s      2099199s   2097152s   primary   ntfs
 2      2099200s   2242559s   143360s    primary   ext4         boot
 3      2242560s   4339711s   2097152s   primary
 4      4339712s   67108863s  62769152s  extended
 5      4341760s   28917759s  24576000s  logical
 6      28919808s  67108863s  38189056s  logical                lvm
Comment 51 Chris Murphy 2013-08-13 10:48:40 EDT
> (In reply to Steve Tyler from comment #49)
>installer allows installation to begin with a 70 MiB /boot

It's probably worth a separate bug against anaconda, as this would be a blocking bug for the installer to crash for an obviously invalid layout. The installer should enforce a minimum size in Manual Partitioning.
Comment 52 Steve Tyler 2013-08-13 11:11:44 EDT
Thanks for suggesting that. I forgot to post a cross-reference:
Bug 996509 - bootloader install fails after installer accepts 70 MiB /boot partition
Comment 53 David Shea 2013-09-03 11:44:43 EDT

*** This bug has been marked as a duplicate of bug 986431 ***

Note You need to log in before you can comment on or make changes to this bug.