Bug 969699 - Any active text input freezes Qt apps in current F19
Any active text input freezes Qt apps in current F19
Status: CLOSED DUPLICATE of bug 968794
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-06-01 18:35 EDT by Linus Torvalds
Modified: 2013-06-01 18:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-06-01 18:44:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2013-06-01 18:35:25 EDT
Description of problem:

Qt applications (current builds of the Qt version of "subsurface", but also things like "qt-creator" that comes with Fedora 19) lock up whenever a text field becomes active.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run "qtcreator some-file-to-edit"
2. Try to mnove around in the text with the cursor keys
3. Profit!

Actual results:

Hung application - trying to close it from the upper right corner will (after the five-second pause) result in "Qt Creeator is not responding" and "You may choose to wait a short while for it to continue or force the application to quit"

Expected results:

Able to move around and edit the file or text field.

NOTE! Qt-creator is just an example. It is not limited to Qt-creator.

Additional info:

This is an up-to-date as of today install of F19.
Comment 1 Rex Dieter 2013-06-01 18:44:09 EDT

and bug #968794

*** This bug has been marked as a duplicate of bug 968794 ***
Comment 2 Rex Dieter 2013-06-01 18:45:00 EDT
At least, I'm hoping it was the problematic qt-4.8.4-18.fc19 build to blame here.  holler if you have evidence to the contrary.

Note You need to log in before you can comment on or make changes to this bug.