Bug 968794 - KDE keyboard input impossible with ibus enabled and qt updated to 4.8.4-18
KDE keyboard input impossible with ibus enabled and qt updated to 4.8.4-18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 969130 969699 (view as bug list)
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-29 22:17 EDT by Ed Greshko
Modified: 2014-02-06 10:55 EST (History)
15 users (show)

See Also:
Fixed In Version: qt-4.8.4-19.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 23:15:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-27809 None None None Never

  None (edit)
Description Ed Greshko 2013-05-29 22:17:47 EDT
Description of problem: After updating to qt-4.8.4-17.fc19.x86_64 data entry via keyboard is impossible with ibus enabled


Version-Release number of selected component (if applicable): qt-4.8.4-17.fc19.x86_64


How reproducible: 


Steps to Reproduce:
1. Install F19-B-RC4 KDE Desktop from DVD
2. Enable the ibus input method.  Everything works fine
3. Update all packages except for qt*  
4. Everything still works fine.
5. Do "yum update qt* and the following get updated....
qt.x86_64
qt-mysql.x86_64
qt-settings.noarch
qt-x11.x86_64
6. Log Out and Login
7. Unable to type into konsole or any app.

Actual results:


Expected results:


Additional info:
Comment 1 Ed Greshko 2013-05-29 22:44:04 EDT
Also, with the latest version of qt installed the clipboard icon and volume icon fail to appear on the systray.
Comment 2 Adam Williamson 2013-05-29 22:47:24 EDT
Let's nominate this as a final blocker, it's pretty showstopper-y for people who rely on ibus input.
Comment 3 Vojtěch Boček 2013-05-30 10:38:10 EDT
I was able to reproduce this in KVM, Fedora 19 Beta RC4 x86_64.
Comment 4 Kevin Kofler 2013-05-30 11:36:10 EDT
Comment #1 sounds like kded4 is crashing.
Comment 5 Rex Dieter 2013-05-30 12:18:59 EDT
Other side effects of qt-4.8.4-18 upgrade I noticed:
* (confirming comment #1) many systray apps not appearing (klipper, kmix in particular), or with blank icon (ktp presence applet)
* ktp account manager is empty (prior to 4.8.4-17, I had several accounts configured and working)

As for kded4, I see it running, but apparently no longer running correctly.

'kquitapp kded' makes systray stuff show again (classic mode), and manually re-running kded4 makes systray displays most things now.  ktp is still empty.


I think we have enough evidence to pull the 4.8.4-18 update pending further scrutiny.
Comment 6 Rex Dieter 2013-05-30 13:48:15 EDT
*** Bug 969130 has been marked as a duplicate of this bug. ***
Comment 7 Rex Dieter 2013-05-30 13:50:53 EDT
*** Bug 969130 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2013-05-30 13:51:43 EDT
Discussed at 2013-05-30 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . Accepted as a blocker per criterion "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use" for KDE users who rely on ibus input.

Thanks for withdrawing the update; just read blocker status as meaning 'please don't push this again until it's fixed' :)
Comment 9 Jeff Bastian 2013-05-30 15:19:46 EDT
The kwalletmanager system tray icon is also affected by this bug (it's completely missing like the mixer and klipper icons).  Downgrading to qt-4.8.4-17.fc19.x86_64 fixed it.
Comment 10 Fedora Update System 2013-05-30 16:03:40 EDT
qt-4.8.4-19.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt-4.8.4-19.fc19
Comment 11 Colin J Thomson 2013-05-30 16:08:46 EDT
(In reply to Fedora Update System from comment #10)
> qt-4.8.4-19.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/qt-4.8.4-19.fc19

This update fixes the missing tray icons on this box.
Comment 12 Ed Greshko 2013-05-30 17:44:32 EDT
Verified fix and gave karma
Comment 13 Fedora Update System 2013-05-31 14:11:27 EDT
Package qt-4.8.4-19.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.8.4-19.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9749/qt-4.8.4-19.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-05-31 23:15:47 EDT
qt-4.8.4-19.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Rex Dieter 2013-06-01 18:44:09 EDT
*** Bug 969699 has been marked as a duplicate of this bug. ***
Comment 16 Red Hat Bugzilla 2013-10-03 20:23:01 EDT
Removing external tracker bug with the id '27809' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.