Bug 969740 - SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /home/user9/.config/teamviewer8/drive_c/windows/system32/winemenubuilder.exe.
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /home...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d4a004c5fc8551c5eef2f2d8578...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:44 EDT by Moez Roy
Modified: 2013-06-03 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:05:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:44:19 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /home/user9/.config/teamviewer8/drive_c/windows/system32/winemenubuilder.exe.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that bash should be allowed getattr access on the winemenubuilder.exe file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep TeamViewer_Desk /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/drive_c/windows/sy
                              stem32/winemenubuilder.exe [ file ]
Source                        TeamViewer_Desk
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      0bd3a6f4-4097-4f21-a012-296ffa74df70

Raw Audit Messages
type=AVC msg=audit(1370018847.771:496): avc:  denied  { getattr } for  pid=11249 comm="TeamViewer_Desk" path="/home/user9/.config/teamviewer8/drive_c/windows/system32/winemenubuilder.exe" dev="dm-3" ino=45876415 scontext=system_u:system_r:init_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1370018847.771:496): arch=x86_64 syscall=stat success=yes exit=0 a0=e68c20 a1=7fff73a75f50 a2=7fff73a75f50 a3=8 items=0 ppid=11097 pid=11249 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=TeamViewer_Desk exe=/usr/bin/bash subj=system_u:system_r:init_t:s0 key=(null)

Hash: TeamViewer_Desk,init_t,config_home_t,file,getattr

audit2allow

#============= init_t ==============
allow init_t config_home_t:file getattr;

audit2allow -R
require {
	type init_t;
}

#============= init_t ==============
gnome_read_home_config(init_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:05:04 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.