Bug 969745 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'c...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:43cfab712a70fa27a20b8bd2707...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:48 EDT by Moez Roy
Modified: 2013-06-03 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:48:05 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wine-preloader should be allowed connectto access on the X0 unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep TeamViewer_Desk /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:system_r:xserver_t:s0-s0:c0.c1023
Target Objects                @/tmp/.X11-unix/X0 [ unix_stream_socket ]
Source                        TeamViewer_Desk
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      07b93f77-38f2-4126-bcec-5a4333a9d987

Raw Audit Messages
type=AVC msg=audit(1370018847.894:503): avc:  denied  { connectto } for  pid=11249 comm="TeamViewer_Desk" path=002F746D702F2E5831312D756E69782F5830 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:system_r:xserver_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1370018847.894:503): arch=i386 syscall=getuid success=yes exit=0 a0=3 a1=32eb60 a2=7e19d000 a3=15 items=0 ppid=11097 pid=11249 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=TeamViewer_Desk exe=/opt/teamviewer8/tv_bin/wine/bin/wine-preloader subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: TeamViewer_Desk,initrc_t,xserver_t,unix_stream_socket,connectto

audit2allow

#============= initrc_t ==============
allow initrc_t xserver_t:unix_stream_socket connectto;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
xserver_dontaudit_stream_connect(initrc_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:05:32 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.