Bug 96980 - Must restart irda service after resume
Summary: Must restart irda service after resume
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: irda-utils (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 127585 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-07 19:15 UTC by Mitsu Hadeishi
Modified: 2015-01-08 00:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-16 13:44:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mitsu Hadeishi 2003-06-07 19:15:09 UTC
Description of problem:

After resuming (on a Dell Inspiron 8200) RH9 will fail to communicate with an
IRDA device, requiring a restart of the irda service (via "service irda restart").

Version-Release number of selected component (if applicable):


How reproducible:

Easily reproducible

Steps to Reproduce:
1. Boot RH9 with irda service enabled
2. Place irda device (such as GPRS phone) in communication with irda port on laptop
3. Check communication with irdadump
4. Suspend laptop
5. Resume laptop
6. Check communication with irdadump
    
Actual results:

After resume, irdadump fails to recognize external irda device, even though
irattach is still running

Expected results:

Irda device should be there

Additional info:

Workaround involves restarting irda service

Comment 1 Karsten Hopp 2003-07-03 13:29:56 UTC
Please add irda to the RESTORESERVICES line in /etc/sysconfig/apmd. 
Does this solve your problems ? 

Comment 2 Mitsu Hadeishi 2003-07-04 16:47:46 UTC
Yes, that works.  I would guess that I would recommend that irda be added to
RESTORESERVICES by default.

Comment 3 Karsten Hopp 2003-07-16 13:44:52 UTC
I'll have to check if adding irda to the apmd config file will break other things 

Comment 4 Karsten Hopp 2004-07-09 23:05:50 UTC
*** Bug 127585 has been marked as a duplicate of this bug. ***

Comment 5 Sepehr 2004-07-12 21:54:05 UTC
Nope doesn't work for me. I set changed my /etc/sysconfig/apmd line to: 

RESTORESERVICES="named amd irda"

I also tried irdad too. Neither worked I suspend/resume and irda
doesn't work anymore. I try to restart "/etc/init.d/irda restart" no
good, rebooting seems to be only solution. Again wasn't a problem with
FC1 or RH9 for me.

I also tried to unload the kernel modules (irda and dependants) and
reload but that doesn't solve the problem either.


Note You need to log in before you can comment on or make changes to this bug.