Bug 96982 - parsec is defined incorrectly
Summary: parsec is defined incorrectly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: units (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 97928 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-07 20:13 UTC by Thomas Quinn
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-16 11:19:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Quinn 2003-06-07 20:13:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
In /usr/share/units.dat parsec is defined as:
parsec                  au / tan(arcsec)

which looks correct except that "au" is interpreted as "attoatomicmassunit" not
"astronomicalunit".  The "au" needs to be spelled out to avoid the confusion.



Version-Release number of selected component (if applicable):
units-1.80-4

How reproducible:
Always

Steps to Reproduce:
1. Type "units"
2.  Type "parsecs"
3. Type "km"

Actual Results:  2083 units, 71 prefixes, 32 nonlinear units
 
You have: parsecs
You want: km
conformability error
        3.425107e-40 kg
        1000 m
You have:


Expected Results:  It should have returned the number of kilometers in a parsec.

Additional info:

Comment 1 Harald Hoyer 2003-06-24 09:15:20 UTC
*** Bug 97928 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.