Bug 97928 - "au" not defined; sundist is accordingly defined incorrectly
"au" not defined; sundist is accordingly defined incorrectly
Status: CLOSED DUPLICATE of bug 96982
Product: Red Hat Linux
Classification: Retired
Component: units (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-24 03:51 EDT by Scott Seagroves
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Seagroves 2003-06-24 03:51:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
The documentation for "units" boasts that the AU is one of the defined
quantities --- yes and no.  It is defined as "astronomicalunit" but nowhere is
"au" explicitly defined.  So when you do calculations with "au" units ends up
thinking it is "a" for atto and "u" for atomicmassunit.  

This is bad for two reasons.  One: I figured that since "au" is mentioned on the
manpage (look in the section "Unit Definitions") then I could use it, but in
fact it is not defined.
Two: the "sundist" is defined as (in /usr/share/units.dat)

sundist                 1.0000010178 au # mean earth-sun distance

which is actually an incorrect definition since "au" is interpretted as an
atto-atomicmassunit!

This is similar to bug 96982 where the parsec was defined in terms of "au"; this
has since been fixed in rawhide by changing the definition to be in terms of
astronomicalunit.  I think a better remedy for all these situations would simply
be to add a line

au               astronomicalunit

to /usr/share/units.dat.  How many people will be using au for the
attoatomicmassunit?

Version-Release number of selected component (if applicable):
units-1.80-4 and units-1.80-7.1

How reproducible:
Always

Steps to Reproduce:
1.type "units"

[scott@lobos ~]$ units
2083 units, 71 prefixes, 32 nonlinear units
 
You have:

2.type "sundist" and hit return twice
You have: sundist
You want:
        Definition: 1.0000010178 au = 1.6605404e-45 kg
You have:

3.
    

Actual Results:  You have: sundist
You want:
        Definition: 1.0000010178 au = 1.6605404e-45 kg
You have:


Expected Results:  I should have gotten the earth-sun distance in meters like this:
You have: 1.0000010178 astronomicalunit
You want:
        Definition: 1.4959802e+11 m


Additional info:
Comment 1 Harald Hoyer 2003-06-24 05:15:18 EDT
I know, I know... I reported this upstream already...

*** This bug has been marked as a duplicate of 96982 ***
Comment 2 Harald Hoyer 2003-06-24 05:16:30 EDT
I will push out a new rawhide version today..
Comment 3 Harald Hoyer 2003-06-24 06:58:16 EDT
fixed in units-1.80-8.1
Comment 4 Red Hat Bugzilla 2006-02-21 13:56:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.