Bug 969949 - Qpid exception
Qpid exception
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: beta
: 4.0
Assigned To: Xavier Queralt
Ami Jeain
:
Depends On:
Blocks: 980950
  Show dependency treegraph
 
Reported: 2013-06-03 03:13 EDT by Gary Kotton
Modified: 2016-04-26 18:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.21.b3.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, components that used AMQP for communication would log exceptions while the connection was being closed. Affected components included Compute (openstack-nova-compute), Compute Scheduler (openstack-nova-scheduler), and Compute Conductor (openstack-nova-conductor). These messages were benign. Errors reading from or writing to the recently closed socket are expected and do not require administrator attention. With this fix, AMQP error logging is disabled while the connection is being closed.
Story Points: ---
Clone Of:
: 980950 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:04:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 31496 None None None Never

  None (edit)
Description Gary Kotton 2013-06-03 03:13:12 EDT
Description of problem:
When rebootinng hosts the following execpition is received:

2013-05-29 13:54:45.163 9751 INFO nova.service [-] Caught SIGTERM, exiting
2013-05-29 13:54:45.171 9751 CRITICAL nova [-] need more than 0 values to unpack
2013-05-29 13:54:45.171 9751 TRACE nova Traceback (most recent call last):
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/bin/nova-scheduler", line 56, in <module>
2013-05-29 13:54:45.171 9751 TRACE nova     service.wait()
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/service.py", line 696, in wait
2013-05-29 13:54:45.171 9751 TRACE nova     _launcher.wait()
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/service.py", line 219, in wait
2013-05-29 13:54:45.171 9751 TRACE nova     rpc.cleanup()
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/__init__.py", line 240, in cleanup
2013-05-29 13:54:45.171 9751 TRACE nova     return _get_impl().cleanup()
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/impl_qpid.py", line 649, in cleanup
2013-05-29 13:54:45.171 9751 TRACE nova     return rpc_amqp.cleanup(Connection.pool)
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/amqp.py", line 670, in cleanup
2013-05-29 13:54:45.171 9751 TRACE nova     connection_pool.empty()
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/amqp.py", line 80, in empty
2013-05-29 13:54:45.171 9751 TRACE nova     self.get().close()
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/impl_qpid.py", line 386, in close
2013-05-29 13:54:45.171 9751 TRACE nova     self.connection.close()
2013-05-29 13:54:45.171 9751 TRACE nova   File "<string>", line 6, in close
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 316, in close
2013-05-29 13:54:45.171 9751 TRACE nova     ssn.close(timeout=timeout)
2013-05-29 13:54:45.171 9751 TRACE nova   File "<string>", line 6, in close
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 749, in close
2013-05-29 13:54:45.171 9751 TRACE nova     if not self._ewait(lambda: self.closed, timeout=timeout):
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 566, in _ewait
2013-05-29 13:54:45.171 9751 TRACE nova     result = self.connection._ewait(lambda: self.error or predicate(), timeout)
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 208, in _ewait
2013-05-29 13:54:45.171 9751 TRACE nova     result = self._wait(lambda: self.error or predicate(), timeout)
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/messaging/endpoints.py", line 193, in _wait
2013-05-29 13:54:45.171 9751 TRACE nova     return self._waiter.wait(predicate, timeout=timeout)
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/concurrency.py", line 57, in wait
2013-05-29 13:54:45.171 9751 TRACE nova     self.condition.wait(3)
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/concurrency.py", line 96, in wait
2013-05-29 13:54:45.171 9751 TRACE nova     sw.wait(timeout)
2013-05-29 13:54:45.171 9751 TRACE nova   File "/usr/lib/python2.6/site-packages/qpid/compat.py", line 53, in wait
2013-05-29 13:54:45.171 9751 TRACE nova     ready, _, _ = select([self], [], [], timeout)
2013-05-29 13:54:45.171 9751 TRACE nova ValueError: need more than 0 values to unpack
2013-05-29 13:54:45.171 9751 TRACE nova


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Xavier Queralt 2013-06-21 05:15:16 EDT
This problem has already been fixed upstream and will be included in havana.
Comment 3 Nikola Dipanov 2013-06-21 07:32:45 EDT
The upstream patch seems unobtrusive and an easy candidate for the grizzly/stable branch.

I propose to move this bug to grizzly async and backport the patch after it lands on grizzly stable (or possibly pick it up during the next stable rebase.
Comment 11 Omri Hochman 2013-10-13 06:45:54 EDT
Verified : unable to reproduce with openstack-nova-2013.2-0.24.
(Havana 4.0 - puddle : 2013-10-03.3)
Comment 14 errata-xmlrpc 2013-12-19 19:04:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.