Bug 970242 - Feature request for RHEL6 to read MTP in order to mount newer Samsung Galaxy SIII & other Android 4.x smartphones
Feature request for RHEL6 to read MTP in order to mount newer Samsung Galaxy ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs (Show other bugs)
6.5
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
:
Depends On:
Blocks: 1002711
  Show dependency treegraph
 
Reported: 2013-06-03 15:18 EDT by Rock
Modified: 2015-09-18 09:54 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 09:54:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attempts in Android & Linux forums to get Android 4.x smartphones to work with RHEL6 variants (5.57 MB, application/pdf)
2013-06-03 15:18 EDT, Rock
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 711563 None None None Never

  None (edit)
Description Rock 2013-06-03 15:18:00 EDT
Created attachment 756482 [details]
Attempts in Android & Linux forums to get Android 4.x smartphones to work with RHEL6 variants

Description of problem:
When one connects an ICS Android 4.x smartphone (such as the T-Mobile Samsung Galaxy S3) by USB cable to a RHEL6 system, nothing happens. RHEL6 does not mount the Android file system any more (since Google removed  mass storage code in Ice Cream Sandwich; therefore USBMS mode is no longer available; only MTP & PTP modes are available for ICS devices).

REFERENCE: http://androidforums.com/computers/499522-looking-linux-file-transfer-tool-android-4-0-devices.html

While implicated packages are libmtp & mtpfs (from Sourceforge), this is really a feature request for RHEL6 to gracefully handle MTP devices, and not a specific bug report against those packages per se.

Version-Release number of selected component (if applicable):
a. Android version 4.0.4 Samsung Galaxy SIII (T-Mobile)
b. RHEL6 (and variants)

How reproducible:
A. Simply try to transfer photos or screenshots from an Android 4.x phone to RHEL6 by wire. 
B. Unlock the phone; connect by wire; and try to access the phone from the RHEL6 system. 
C. You will fail (unless you perform heroics)

Steps to Reproduce:
1. Unlock your Android 4.x smartphone & plug it into RHEL6 by USB cable
2. Nothing will happen; that is, it will not mount the file Android file system
3. Even if you run mtpfs from the command line within a few seconds of the connection, it still won't mount

Actual results: These are all workarounds and not solutions!
0. Plugging in the Android 4.x device by wire won't (easily) work.
1. You can plug it into Windows or a Mac & the Android file system will mount
2. You can use Wine on RHEL6 (but that's the same as workaround #1 above)
3. You can use an on-the-go cable & transfer data from Android to USB stick
4. You can buy a microSD card and pop that into the RHEL6 PC
5. You can use a WiFi solution such as AirDroid 
6. You can set up the Android device as an FTP server
7 You can even use the cloud (e.g., dropbox) or email 
8. You can downgrade the Android OS on the smartphone to the prior version (which does work with RHEL6)
9. You can punt altogether & put your android phone in PTP (camera) mode.
10. Or, with heroics, an expert might even be able to get MTP (media) mode to work on RHEL6

See related bug reports (all against Fedora):
a. Fedora abandoned mtpfs (https://bugzilla.redhat.com/show_bug.cgi?id=841260)
b. Fedora is using simple-mtpfs (https://bugzilla.redhat.com/show_bug.cgi?id=841260 & https://bugzilla.redhat.com/show_bug.cgi?id=820583)
c. Fedora simple-mtpfs works (https://bugzilla.redhat.com/show_bug.cgi?id=910207)

Expected results:
A RHEL6 user should be able to plug in an Android 4.x smartphone (i.e., an ICS device) by USB cable and the Android device file system should be available to them on the RHEL6 system.

Additional info:
Details on Centos variants of RHEL6 are here:
https://www.centos.org/modules/newbb/viewtopic.php?topic_id=39977

Similar details are here:
http://androidforums.com/android-lounge/713775-possible-move-files-t-mobile-samsung-galaxy-s3-linux-laptops-via-usb-cable.html#post5768268

An experimental Android package is here:
http://www.android.gs/how-to-enable-usb-mass-storage-on-samsung-galaxy-s3-i9300/
Comment 2 RHEL Product and Program Management 2013-10-13 19:31:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Rock 2013-12-07 14:56:03 EST
Thanks for the courtesy update. I'm sure everyone appreciates the information, since this is the first hit in Google when you search for "redhat samsung galaxy s3 camera", which means others must be linking to this bug report for updates.

Personally, not being able to connect my cellphone to my RHEL6-variant (i.e., CentOS) laptop was the straw that broke the camel's back. in this day and age, to not be able to easily connect a cellphone to a desktop operating system is untenable. 

I have since switched to Ubuntu (13.10),and, while Unity has *other* problems, there are no major hurdles to connecting a cellphone, as there were with CentOS.

So I won't be pushing for this any further; but I hope others, who care to use RHEL/CentOS in a desktop environment, carry the flag forward.

Thank you for your wonderful operating system. I do appreciate your updates.
Comment 8 Chris Williams 2015-09-18 09:54:30 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.