Bug 97027 - redhat-config-network discards entries in /etc/ppp/chap-secrets
Summary: redhat-config-network discards entries in /etc/ppp/chap-secrets
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 97029 (view as bug list)
Depends On:
Blocks: rcn-modem
TreeView+ depends on / blocked
 
Reported: 2003-06-09 11:49 UTC by bastiaan
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version: system-config-network-1.3.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 12:12:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bastiaan 2003-06-09 11:49:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
If you have entries in /etc/ppp/chap-secrets for connections
redhat-config-network does not know about, e.g. for pptp, these entries will be
lost upon a 'File/Save'. 
It does not matter whether these entries are inside the '####
redhat-config-network ....' demarked section or not.
Also it does not matter whether the changes to be saved have anything to do with
PPP / CHAP or not.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. echo '"testclient" "testserver" "testpass"' >> /etc/ppp/chap-secrets
2. start redhat-config-network
3. edit a setting
4. choose 'File/Save'
5. cat /etc/ppp/chap-secrets
    

Actual Results:  The 'testclient' entry is gone.

Expected Results:  The 'testclient' entry should have stayed in place.

Additional info:

Comment 1 bastiaan 2003-06-09 12:17:07 UTC
Version-Release number of selected component (if applicable):
redhat-config-network-1.2.3-3

Comment 2 Harald Hoyer 2003-06-10 15:17:33 UTC
Please try:
ftp://people.redhat.com/harald/redhat-config-network/1.2.9-RH9/

and downgrade rhpl, if necessary with --force :)

Comment 3 Harald Hoyer 2003-06-10 15:18:09 UTC
*** Bug 97029 has been marked as a duplicate of this bug. ***

Comment 4 bastiaan 2003-06-10 19:35:34 UTC
OK, I up- and downgraded to 
redhat-config-network-1.2.9-1
redhat-config-network-tui-1.2.9-1
rhpl-0.93.2-1

Now redhat-config-network fails to startup. Traceback:

Component: redhat-config-network
Version: 1.2.9
Summary: TB NCDevADSL.py:33:load:NameError: global name 'ConfDevice' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 156, in main
    window = mainDialog()
  File
"/var/tmp/redhat-config-network-1.2.9-root/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 169, in __init__
  File
"/var/tmp/redhat-config-network-1.2.9-root/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 238, in load
  File
"/var/tmp/redhat-config-network-1.2.9-root/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 245, in loadDevices
  File
"/var/tmp/redhat-config-network-1.2.9-root/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 263, in getDeviceList
  File
"/var/tmp/redhat-config-network-1.2.9-root/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 117, in load
  File
"/var/tmp/redhat-config-network-1.2.9-root/usr/share/redhat-config-network/netconfpkg/plugins/NCDevADSL.py",
line 33, in load
NameError: global name 'ConfDevice' is not defined
 
Local variables in innermost frame:
self: Device.Type=xDSL
 
name: DePoort




Comment 5 Harald Hoyer 2003-06-11 07:41:04 UTC
ok, second try, same ftp location, version 1.2.9-2

Comment 6 bastiaan 2003-06-11 20:25:42 UTC
upgraded to redhatc-config-network-1.2.9-2 and rhpl-0.105.1-2.

This is much bettter:
* It does not crash on start
* It remembers the password for the xDSL connection

Some things are still broken:
* It still discards my PPTP passwords in /etc/ppp/chap-secrets. Surprisingly
enough it leaves the comments by pptp-php-gtk.php intact.
* If you change the login name of the xDSL connection, redhat-config-network,
does create a new entry with the name in /etc/ppp/chap-secrets, but does not
remove the old entry.

Something that may or not be intended behaviour:
redhat-config-network actually creates two lines in chap-secrets:
"username" <tab> "nickname" <tab> "password"
"username" <tab> * <tab> "password"

The second line will generate a conflict if you have another PPP connection with
the same username.

Also, at least in my case the server field should not contain the device
nickname but the AC-Name. (I've worked around this by choosing the nickname of
the device to equal the AC-Name, but this results in problems when trying to
enable the device at boot time, see bug #97030).
    



Note You need to log in before you can comment on or make changes to this bug.