Bug 97044 - prompted for drivers for CD ROM when installation runs from CDROM
prompted for drivers for CD ROM when installation runs from CDROM
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-06-09 12:25 EDT by John
Modified: 2007-03-27 00:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:41:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John 2003-06-09 12:25:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 

Description of problem:
downloaded RH9 iso and burned to CD. booted to installer with CD, and prompted 
for language and then key board. then prompted for iso location choose local 
CD Rom and prompted to choose a device driver the only one listed is a USB 
mass storage device, when selected device cannot be detected, and only other 
choice to supply a driver diskette.  i am  attempting to load on a SONY VAIO 
laptop that uses an external CD rom with a PCIMCIA interface, that I 
successfully loaded RH8 on with no such problem.  Please advise.



Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot from CD

Expected Results:  IF the installation is running from the CD ROM, it should 
not require further detection.

Additional info:
Comment 1 John 2003-06-09 19:42:20 EDT
in attempt to work around created driver diskette using rawrite and specifing 
image file drvblock.img from rh9 cd1.  installer could not find compatible 
Comment 2 Michael Fulbright 2003-06-10 14:48:24 EDT
Mike do we have similar PCMCIA hardware to test this configuration?
Comment 3 John 2003-06-13 17:48:12 EDT
Please bear in mind that although this CD ROM uses a PCMCIA interface is in an 
ATAPI CD ROM.  Also I burned a CD using the PMCIA boot image and it did not 
run the installer at all.
Comment 4 Mike McLean 2003-06-23 16:44:16 EDT
There is an outstanding bug (bug#83668) with RHL-9 regarding a Sony vaio pcmcia
cdrom (PCGA-CD51/A) not working.  Not all pcmcia cdroms are affected (the
traveller 3220 pcmcia cdrom I have works fine with RHL-9).

This may be a dup of bug#83668.  John, when you attempt your install from pcmcia
cdrom, do you see any message like "ide-cs: GetNextTuple: No more items" on VC3?

Also could you try to install via a different method (nfs, http, harddrive, etc)
and check whether or not the pcmcia cdrom works post-install?
Comment 5 John 2003-06-28 12:49:27 EDT
can you supply a driver diskette that works?
Comment 6 Mike McLean 2003-06-30 11:45:35 EDT
There is not a driver disk to fix bug#83668 that I know of.

Can you please help me determine whether or not you are encountering the same
problem or a different one?
 * when you attempt your install from pcmcia cdrom, do you see any message like
"ide-cs: GetNextTuple: No more items" on VC3?
 * if you install via a different method, does the cdrom work post-install?
Comment 7 John 2003-07-13 00:34:26 EDT
this may be a dupe, but I do not receive the errors that that you listed. I 
have also tried to install with a MicroSolutions 163550 CDROM and aboot 
diskette but my results have not changed.
Comment 8 John 2003-07-13 01:17:28 EDT
I also tried to load the pcmcia.img image from diskette, and it makes the 
install hang.
Comment 9 John 2003-07-15 17:44:48 EDT
I was reading the bug 83668, and saw that RH9 was already installed on their 
system and once the CD ROM was added they received that error.  My problem 
occurs during the install process, what is troubling is that my issue has not 
been addressed in any way, whatsoever.  The install runs from this CDROM a PCG-
CD51/A and loads it,  If the installer runs from the CDROM why then does it 
need additional drivers?
Comment 10 Jeremy Katz 2003-07-24 19:09:18 EDT
Booting with 'linux pci=off ide1=0x180,0x386' should allow this to work.
Comment 11 John 2003-07-26 01:02:40 EDT
I tried this command line, it still prompted for a driver diskette, please 
supply me with one.
Comment 12 Jeremy Katz 2003-07-29 11:16:16 EDT
Just say that you don't need one and continue on
Comment 13 John 2003-08-01 07:47:43 EDT
It does not work if you continue, and choose the local CD ROM as the source 
for the install files, the install program states that it cannot be found, 
please supply a driver diskette!!!
Comment 14 Quentin Arce 2003-08-31 01:57:48 EDT
Hello,  So I have had this same problem with the Ninja cdrom for My Sony Viao
laptop.  In the end I borrowed a friends sony dvd-rom drive and was able to
install with out any problems ... Once installed I tried my cdrom drive again
and ... I was given the error you noted above...  "ide-cs: GetNextTuple: No more
items"  Redhat 8 and 7.3 do not have this problem.  Debain woody does, Gentoo1.4
install Image does, and Mandrake9.1 .  In the end I used a RH 7.3 installer in
rescue mode to then built the system by hand.  Tared up all the tools I needed,
copied them onto the Window$ partition, mounted the window$ part.  untared the
tools and build a gentoo laptop... As my laptop is slow I am now going back to
Redhat 8 in order to get updates faster than overnight.  I would LOVE to run
Redhat 9 as I do on my PC at work.  Please figure out what is wrong with the
installer/ide-cd driver.  If I had the time I would look at the diff of the two
versions used in 8 and 9.  

Just in case I try to look at this... what have you (Red Hat) looked at thus
far... have you seen this error.  Do you know what causes it?

Comment 15 John 2003-09-21 01:05:51 EDT
Are we ever going to get some resolution?  
Comment 16 Jeremy Katz 2003-09-25 16:36:08 EDT
There was a change between 2.4.18 and 2.4.20 that seems to have caused this (and
it might be partially related to the port range changes to stop crashing Radeon
IGP as well)
Comment 17 John 2003-09-28 09:20:11 EDT
that's really nice, but i reported this bug in June, in three months I have 
not gotten resolution. I work for a company that is a top ten ATT client, as 
well as being listed in the top fifty in the info week 500.  As a result of 
the numerous problems that RH9 has, my company has utilized RH8 in on of the 
few Linux solution we deliver.  It is disappointing to realize that your 
product will never be an adequate solution to replace windows as a end user 
OS, but based on my experience here, you've done nothing but confirm it.
Comment 18 Dave Jones 2003-09-28 09:31:56 EDT
I can't reproduce this. I've got to specify the arguments mentioned in comment
#10, but that's always been the case since I first got my vaio.  The only
difference in recent times has been requirement of the pci=off argument.

With these specified, my vaio happily installs from CD on RHL9 and Fedora.
Comment 19 Bugzilla owner 2004-09-30 11:41:05 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.