Bug 970581 - [RHSC] Volume Options Pull Down List Auto Collapse
[RHSC] Volume Options Pull Down List Auto Collapse
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Prasanth
: ZStream
: 999830 (view as bug list)
Depends On:
Blocks: 957769
  Show dependency treegraph
 
Reported: 2013-06-04 08:08 EDT by Matt Mahoney
Modified: 2016-04-18 06:06 EDT (History)
12 users (show)

See Also:
Fixed In Version: cb3
Doc Type: Bug Fix
Doc Text:
Previously, the Option Key drop-down list in Add Option window of Volume Options was getting collapsed automatically. Now, the Option Key drop-down list is displayed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:29:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (2.23 MB, application/x-xz)
2013-08-23 04:05 EDT, Prasanth
no flags Details
page 7 (194.66 KB, application/pdf)
2013-08-27 02:49 EDT, Pavithra
no flags Details

  None (edit)
Description Matt Mahoney 2013-06-04 08:08:00 EDT
Description of problem:
When attempting to select a Volume Option from the Volume Options pull down list, the list at times auto collapse before the user has made the options selection. This is an intermittent issue, such that there is not a consistent set of steps to reproduce.

Version-Release number of selected component (if applicable):

bb1

How reproducible:


Steps to Reproduce:
1. Navigate to the Volumes Tab
2. Select Volume
3. Click to Volume Options bug-tab
4. Click Add button
5. Select Option Key pulldown list (on Add Option dialog)

Actual results:
The list will at times auto collapse prior to the user selecting the desired volume option. 

Expected results:


Additional info:
Comment 2 Prasanth 2013-08-22 06:33:51 EDT
The drop-down list gets refreshed every few seconds and the list collapses making it difficult for the user to select the desired option from the list.


This is happening always in  Red Hat Storage Console Version: 2.1.0-0.bb9.el6rhs
Comment 3 Prasanth 2013-08-22 06:35:02 EDT
*** Bug 999830 has been marked as a duplicate of this bug. ***
Comment 4 Prasanth 2013-08-23 04:05:50 EDT
Created attachment 789496 [details]
engine logs
Comment 5 Kanagaraj 2013-08-26 04:54:46 EDT
The volume options drop down is getting collapsed because of the component losing the focus. Also If the user start typing something in the option value text field, after entering some text the field will lose the focus.

The same issue can be reproduced in the Cluster tab by the following steps.
1) Go to Clusters tab
2) Create a new cluster named 'c1'
3) Select the 'Default' cluster in the table
4) Click on 'New' action, New Cluster popup will open, then start typing the name (give some sec delay b/w each charecters), the field will lose the focus.

The issue is fixed upstream in the patch http://gerrit.ovirt.org/#/c/16739/

But this patch has lot of framework upgrades, it will be a high risk if we want to include this in the 2.1 release.
Comment 6 Scott Haines 2013-08-26 08:32:41 EDT
Per dpati, now targeting for Corbett.
Comment 7 Pavithra 2013-08-27 02:48:52 EDT
This issue is now documented in the release notes on page 7.
Comment 8 Pavithra 2013-08-27 02:49:29 EDT
Created attachment 790797 [details]
page 7
Comment 9 Scott Haines 2013-09-23 19:18:51 EDT
Retargeting for 2.1.z U2 (Corbett) release.
Comment 10 Prasanth 2013-10-17 06:54:55 EDT
Verified as fixed in cb3. 

Volume options pull down list is not auto collapsing anymore.
Comment 11 Shalaka 2014-01-21 01:47:54 EST
Please review the edited DocText and signoff.
Comment 12 Shalaka 2014-01-21 01:48:09 EST
Please review the edited DocText and signoff.
Comment 13 Kanagaraj 2014-01-21 01:55:58 EST
doc_text looks good.
Comment 15 errata-xmlrpc 2014-02-25 02:29:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.