Bug 970663 - Provide more information for failure to create content
Provide more information for failure to create content
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Og Maciel
http://projects.theforeman.org/issues...
: Triaged
: 968774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 10:18 EDT by Og Maciel
Modified: 2016-04-22 11:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:21:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 2615 None None None 2016-04-22 11:45 EDT

  None (edit)
Description Og Maciel 2013-06-04 10:18:18 EDT
Description of problem:

While creating a new host group (see https://bugzilla.redhat.com/show_bug.cgi?id=970662) I noticed that Foreman was not providing the true reason as to why there was a failure. It would be great if we could be more verbose about these types of failures as well as bubble up a user friendly message to the user in the UI. All the logs show is a generic "Failed to save: " message and there's no indication in the UI as to what failed.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-ec2-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10002-44.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.15-1.el6sat.noarch
* signo-katello-0.0.15-1.el6sat.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Started POST "/foreman/hostgroups" for 127.0.0.1 at 2013-06-04 09:43:28 -0400
Processing by HostgroupsController#create as HTML
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"2aMzo6DbPV6vgYHtNcPVPpb04gzGDAHqb/k5vAfWA5s=", "hostgroup"=>{"parent_id"=>"", "name"=>"qegroup2", "environment_id"=>"7", "puppet_ca_proxy_id"=>"1", "puppet_proxy_id"=>"1", "puppetclass_ids"=>[""], "domain_id"=>"3", "subnet_id"=>"1", "architecture_id"=>"1", "operatingsystem_id"=>"1", "medium_id"=>"6", "ptable_id"=>"1", "root_pass"=>"[FILTERED]", "group_parameters_attributes"=>{"1370353408723"=>{"name"=>"kt_activation_keys", "value"=>"[FILTERED]", "_destroy"=>"kt_activation_keys", "nested"=>""}, "1370353408733"=>{"name"=>"kt_org", "value"=>"[FILTERED]", "_destroy"=>"kt_org", "nested"=>""}, "1370353408739"=>{"name"=>"kt_env", "value"=>"[FILTERED]", "_destroy"=>"kt_env", "nested"=>""}, "1370353408745"=>{"name"=>"kt_cv", "value"=>"[FILTERED]", "_destroy"=>"kt_cv", "nested"=>""}}, "organization_ids"=>["", "", "2"]}, "kt_activation_keys"=>"ActivationKey1", "commit"=>"Submit"}
Failed to save: 
  Rendered puppetclasses/_selectedClasses.html.erb (0.0ms)
  Rendered puppetclasses/_classes.html.erb (3.3ms)
  Rendered puppetclasses/_class_selection.html.erb (7.4ms)
  Rendered common/_domain.html.erb (6.5ms)
  Rendered common/_domain_subnet.html.erb (11.5ms)
  Rendered common/os_selection/_architecture.html.erb (3.1ms)
  Rendered common/os_selection/_operatingsystem.html.erb (6.0ms)
  Rendered common/os_selection/_initial.html.erb (11.3ms)
  Rendered puppetclasses/_class_parameters.html.erb (0.0ms)
  Rendered puppetclasses/_classes_parameters.html.erb (5.0ms)
  Rendered common_parameters/_puppetclass_parameter.erb (2.7ms)
  Rendered common_parameters/_puppetclasses_parameters.erb (4.7ms)
  Rendered common_parameters/_parameter.erb (1.7ms)
  Rendered common_parameters/_parameter.erb (1.6ms)
  Rendered common_parameters/_parameter.erb (1.3ms)
  Rendered common_parameters/_parameter.erb (1.0ms)
  Rendered common_parameters/_parameter.erb (1.0ms)
  Rendered common_parameters/_parameters.erb (9.6ms)
  Rendered hostgroups/_form.html.erb (75.8ms)
  Rendered hostgroups/new.html.erb within layouts/application (76.2ms)
  Rendered home/_user_dropdown.html.erb (0.9ms)
Read fragment views/tabs_and_title_records-1 (0.1ms)
  Rendered home/_topbar.html.erb (1.3ms)
Completed 200 OK in 236ms (Views: 69.0ms | ActiveRecord: 34.6ms)


Started GET "/foreman/foreman_katello_engine/activation_keys?environment_id=7" for 127.0.0.1 at 2013-06-04 09:43:29 -0400
Processing by ForemanKatelloEngine::ActivationKeysController#index as */*
  Parameters: {"environment_id"=>"7"}
Completed 200 OK in 510ms (Views: 0.5ms | ActiveRecord: 1.5ms)
Comment 1 Marek Hulan 2013-06-05 04:53:41 EDT
This one seems to be related only to environments created from Katello
Comment 2 Marek Hulan 2013-06-06 03:29:43 EDT
awaiting review in https://github.com/theforeman/foreman/pull/695
Comment 3 Marek Hulan 2013-06-11 07:07:27 EDT
Merged in https://github.com/theforeman/foreman/commit/410505f
Comment 4 Marek Hulan 2013-06-11 07:09:40 EDT
*** Bug 968774 has been marked as a duplicate of this bug. ***
Comment 5 Sam Kottler 2013-06-11 15:51:32 EDT
Moved to ON_QA as part of puddle 4.5.
Comment 6 Tazim Kolhar 2013-06-12 03:10:06 EDT
Hi,

  Please provide verification steps

Thanks
Comment 7 Corey Welton 2013-06-12 16:29:54 EDT
(fixing needinfo)
Comment 8 Corey Welton 2013-06-18 15:48:38 EDT
Reading the github, I'm not so sure the issue was necessarily fixed, either.  omaciel is/was looking for certain verbosity for such error messages in logs and UI, whereas the fix for this (may have?) been to resolve the issue that was causing the error.

If that defect is fixed, I suppose I can verify it, but I'm not so certain we won't see the (lack of) error messaging in logs/UI appear in some other edge case.
Comment 9 Marek Hulan 2013-06-19 02:50:55 EDT
The bug as was described occurred only in specific scenario. Errors were displayed on casual validations, only when saving crashed because of current organization was selected, hostgroup was not saved and no errors were displayed.  

However this was not a validation error. It was bug in creation process. So the solution was not to display an error but fix the bug. Adding any more error logging in here does not make sense to me. Only thing we can tell is that some unknown error occurred which is already logged.

The only thing that comes to my mind is we could enforce record saving with .save! method to obtain expcetion message however calling this in "already failed" branch could create inconsistency for example when the first save fail because of network problem.
Comment 10 Og Maciel 2013-06-19 08:33:23 EDT
Fixing the bug was definitely a good thing but I'm not sure I agree with the logic behind not adding more logging. Anyhow, have not seen this happen with latest code so I'll mark it as VERIFIED:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10011-1.noarch
* foreman-compute-1.1.10011-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10011-1.noarch
* foreman-postgresql-1.1.10011-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-14.el6sat.noarch
* katello-all-1.4.2-14.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-14.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-14.el6sat.noarch
* katello-glue-candlepin-1.4.2-14.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
* katello-glue-pulp-1.4.2-14.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
* pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
* pulp-server-2.1.2-0.3.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.18-1.el6sat.noarch
* signo-katello-0.0.18-1.el6sat.noarch
Comment 11 Mike McCune 2013-07-18 17:21:16 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.