Bug 970784 - Provisioning/deployment of new applications are not adapted into the inventory
Provisioning/deployment of new applications are not adapted into the inventory
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.1.2
x86_64 Linux
unspecified Severity medium
: ER04
: JON 3.3.0
Assigned To: Michael Burman
Armine Hovsepyan
:
: 714785 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 17:30 EDT by Peter Larsen
Modified: 2015-09-02 20:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:04:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bundle receipee (641 bytes, text/xml)
2013-06-04 17:30 EDT, Peter Larsen
no flags Details
Sample small app for deployment (2.02 KB, multipart/x-zip)
2013-06-04 17:31 EDT, Peter Larsen
no flags Details
delay (95.89 KB, image/png)
2014-10-08 05:42 EDT, Armine Hovsepyan
no flags Details
auto-discovery (171.56 KB, image/png)
2014-10-08 05:42 EDT, Armine Hovsepyan
no flags Details
discovery-scan-0-delay (375.74 KB, image/png)
2014-10-08 05:59 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Peter Larsen 2013-06-04 17:30:21 EDT
Created attachment 756954 [details]
Bundle receipee

Description of problem:

Simply bundle deployments of EAR/WAR files are not added to the inventory after the deployment has successfully completed. A manual discovery run on the agent is required.

Version-Release number of selected component (if applicable):

3.1.2

How reproducible:

Every time.

Steps to Reproduce:

1. Install new EAP instance. 
2. Discovery instance and add to inventory
3. Create compatible group for just the new server
4. Upload attached bundle recipe and provided zip file
5. Got to http://server:8080/guess - app responds
6. App is not in the inventory
7. Run "discovery -f" on the agent
8. Refresh left side node in JON
9. Deployment now appears


Additional info:
Comment 1 Peter Larsen 2013-06-04 17:31:46 EDT
Created attachment 756955 [details]
Sample small app for deployment
Comment 2 Heiko W. Rupp 2013-08-28 07:38:21 EDT
Peter,
is your report especially about bundles and EAP6 (I know that this is a general issue)?
Comment 3 Peter Larsen 2013-08-28 11:10:05 EDT
(In reply to Heiko W. Rupp from comment #2)
> Peter,
> is your report especially about bundles and EAP6 (I know that this is a
> general issue)?

Heiko, I have not tested on multiple versions of EAP - but the problem looks generic to me when it comes to bundle deployments. Since the bundle has a <deploy> function, it does not make sense I have to scan for new applications when an application is deployed this way.
Comment 5 Jay Shaughnessy 2014-09-03 16:14:38 EDT
This is well known but still not done, we should kick off a discovery after deploying a bundle.

Let's see if we can do this for 3.3.0.
Comment 6 Michael Burman 2014-09-06 05:29:56 EDT
This is now PR #123
Comment 7 Thomas Segismont 2014-09-10 06:41:51 EDT
*** Bug 714785 has been marked as a duplicate of this bug. ***
Comment 9 Michael Burman 2014-09-23 12:59:18 EDT
Fixed in master:

commit 0648f50f8c09590a2446ad48eed9a5a5d6e21371
Merge: 213427f 436fe78
Author: Michael Burman <yak@iki.fi>
Date:   Tue Sep 23 19:57:58 2014 +0300

    Merge pull request #123 from burmanm/BZ970784
    
    [BZ 970784] After successful deployment, initiate discovery scan for affected resources on the agent side.
    
    Add new column DEPLOYMENT_DELAY_IN_SECONDS to BundleDeployment
    Add new message view_bundle_deployWizard_discoveryDelay
    Allow changing the discoveryDelay from recipe (org.rhq.discoveryDelay property) as well as from the UI. If previous liveDeployment had a different v
    Allow recipe to override values also when using the CLI

commit 436fe78abebad925ebc6e8159f582e6636987a17
Author: Michael Burman <miburman@redhat.com>
Date:   Sat Sep 6 12:10:03 2014 +0300

    [BZ 970784] After successful deployment, initiate discovery scan for affected resources on the agent side.
    
     Add new column DEPLOYMENT_DELAY_IN_SECONDS to BundleDeployment
    
    Add new message view_bundle_deployWizard_discoveryDelay
    
    Allow changing the discoveryDelay from recipe (org.rhq.discoveryDelay property) as well as from the UI. If previous liveDeployment had a different v
    
    Allow recipe to override values also when using the CLI
Comment 10 Libor Zoubek 2014-09-24 08:55:18 EDT
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/03d0f99ba
time:    2014-09-24 14:52:21 +0200
commit:  03d0f99ba46b84148c03217cf8fd361465a20b62
author:  Michael Burman - miburman@redhat.com
message: [BZ 970784] After successful deployment, initiate discovery scan for
         affected resources on the agent side.
          Add new column DEPLOYMENT_DELAY_IN_SECONDS to BundleDeployment
         Add new message view_bundle_deployWizard_discoveryDelay
         Allow changing the discoveryDelay from recipe
         (org.rhq.discoveryDelay property) as well as from the UI. If
         previous liveDeployment had a different value, use that one.
         Allow recipe to override values also when using the CLI
         (cherry picked from commit
         436fe78abebad925ebc6e8159f582e6636987a17) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>
         Conflicts:
         modules/core/client-api/intentional-api-changes-since-4.12.0.xml
          modules/core/dbutils/pom.xml
         db.version changed in 
         modules/core/dbutils/src/main/scripts/dbupgrade/db-upgrade.xml
         from 2.162 to 2.161 since 3.3x is 1 point behind master
Comment 11 Simeon Pinder 2014-10-01 17:33:28 EDT
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959
Comment 12 Armine Hovsepyan 2014-10-08 05:42:17 EDT
Created attachment 944893 [details]
delay
Comment 13 Armine Hovsepyan 2014-10-08 05:42:42 EDT
Created attachment 944896 [details]
auto-discovery
Comment 14 Armine Hovsepyan 2014-10-08 05:59:20 EDT
verified in JON 3.3 ER04
auto-discovery scan takes part after deploymentDelay, default delay=30sec
if deploymentDelay is 0 -- auto-discovery scan performed simultaneously with deployment
Comment 15 Armine Hovsepyan 2014-10-08 05:59:51 EDT
Created attachment 944921 [details]
discovery-scan-0-delay

Note You need to log in before you can comment on or make changes to this bug.