This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 97084 - mkinitd fails to detect rootfs on commented out /etc/fstab
mkinitd fails to detect rootfs on commented out /etc/fstab
Status: CLOSED DUPLICATE of bug 65249
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-10 00:02 EDT by Elan Ruusamäe
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix the issue (491 bytes, patch)
2003-06-10 00:04 EDT, Elan Ruusamäe
no flags Details | Diff

  None (edit)
Description Elan Ruusamäe 2003-06-10 00:02:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; UNIX) Opera 7.10  [en]

Description of problem:
mkinitd fails to detect rootfs when commented out entry present for '/' in 
/etc/fstab and therefore thinks rootfs is on LVM, which invokes lvmscan, which 
is not installed on system.

here's revelant part of code run:

++ awk '{ if ($2 == "/") { print $1; }}' /etc/fstab
+ rootdev=#LABEL=/
/dev/hda2
+ echo '#LABEL=/' /dev/hda2
+ cut -d/ -f3
+ grep loop
+ echo '#LABEL=/' /dev/hda2
+ cut -c1-6
+ grep LABEL=
++ ls -l '#LABEL=/
/dev/hda2'
ls: #LABEL=/
/dev/hda2: No such file or directory
++ sed -e 's/.* \([0-9]\+\), *[0-9]\+.*/\1/'
+ major=
+ '[' '' -ne 58 ']'
/sbin/mkinitrd: line 357: [: : integer expression expected
+ root_lvm=1





Version-Release number of selected component (if applicable):
mkinitrd-3.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.add '#LABEL=/ /' to /etc/fstab
2.run mkinitrd

    

Additional info:
Comment 1 Elan Ruusamäe 2003-06-10 00:04:21 EDT
Created attachment 92291 [details]
patch to fix the issue
Comment 2 Jeremy Katz 2003-06-10 23:33:04 EDT

*** This bug has been marked as a duplicate of 65249 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.