Bug 970981 - RFE: Need to rebase python-urwid on latest upstream
RFE: Need to rebase python-urwid on latest upstream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-urwid (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Andy Grover
Branislav Blaškovič
: FutureFeature, Rebase
Depends On:
Blocks: 883504 911398 911400 927543
  Show dependency treegraph
 
Reported: 2013-06-05 07:41 EDT by Mike Burns
Modified: 2013-11-21 00:41 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 00:41:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1550 normal SHIPPED_LIVE python-urwid bug fix and enhancement update 2013-11-20 16:40:34 EST

  None (edit)
Description Mike Burns 2013-06-05 07:41:01 EDT
Description of problem:
ovirt-node/RHEV-H has a dependency on python-urwid for it's new UI (our headline feature in 6.5).  It turns out that there are a number of incompatibilities between the version upstream (1.1.1-1) and the version in EL6 (0.9.9-4).  

We would like to rebase 6.5 to the newer version in Fedora.
Comment 2 Mike Burns 2013-06-05 07:53:29 EDT
Current dependency chain for python-urwid:

python-urwid-0.9.9.1-4.el6.x86_64 [cmd line]
 \_  1:python-configshell-1.1.fb4-1.el6.noarch [1: python-urwid = 0.9.9.1-4.el6]
 |   \_  fcoe-target-utils-2.0rc1.fb16-3.el6.noarch [1: python-configshell = 1:1.1.fb4-1.el6]
Comment 17 Bruno Goncalves 2013-09-06 04:08:05 EDT
targetcli seems to work fine with:

rpm -q python-urwid
python-urwid-1.1.1-1.el6.x86_64

rpm -q fcoe-target-utils
fcoe-target-utils-2.0rc1.fb16-5.el6.noarch
Comment 23 Branislav Blaškovič 2013-10-31 02:00:27 EDT
Thank you! So python-urwid is prepared now.
Comment 25 errata-xmlrpc 2013-11-21 00:41:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1550.html

Note You need to log in before you can comment on or make changes to this bug.