This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 971027 - automount cannot mount into public_content_t
automount cannot mount into public_content_t
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Michal Trunecka
:
Depends On:
Blocks: 971814
  Show dependency treegraph
 
Reported: 2013-06-05 09:37 EDT by Michal Trunecka
Modified: 2014-09-30 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 971814 976361 (view as bug list)
Environment:
Last Closed: 2014-06-13 08:23:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Trunecka 2013-06-05 09:37:20 EDT
Description of problem:
automount cannot mount into public_content_t, which fails with avc. Since ftpd can read/write to autofs_t and nfs_t using corresponding booleans, I would expect I can mount dirs into /var/ftp directory, which has public_content_t by default.


----
time->Wed Jun  5 13:39:09 2013
type=SYSCALL msg=audit(1370435949.472:2364): arch=c000003e syscall=165 success=no exit=-13 a0=7fcd30931950 a1=7fcd180008c0 a2=7fcd2fab7d98 a3=c0ed0000 items=0 ppid=19203 pid=19214 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm="automount" exe="/usr/sbin/automount" subj=system_u:system_r:automount_t:s0 key=(null)
type=AVC msg=audit(1370435949.472:2364): avc:  denied  { mounton } for  pid=19214 comm="automount" path="/var/ftp" dev="dm-1" ino=315097 scontext=system_u:system_r:automount_t:s0 tcontext=system_u:object_r:public_content_t:s0 tclass=dir



Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-48.el7.noarch
Comment 2 Ludek Smid 2014-06-13 08:23:00 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.