Bug 976361 - automount cannot mount into public_content_t
automount cannot mount into public_content_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.10
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 08:43 EDT by Milos Malik
Modified: 2013-09-30 18:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-344.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 971027
Environment:
Last Closed: 2013-09-30 18:25:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2013-06-20 08:43:59 EDT
Description of problem:
automount cannot mount into public_content_t, which fails with avc. Since ftpd can read/write to autofs_t and nfs_t using corresponding booleans, I would expect I can mount dirs into /var/ftp directory, which has public_content_t by default.

----
time->Tue Jun 18 21:03:38 2013
type=SYSCALL msg=audit(1371603818.619:1148): arch=c000003e syscall=165 success=no exit=-13 a0=2b2ef4beddd0 a1=2b2ef4bdb290 a2=2b2edb588933 a3=c0ed0000 items=0 ppid=28917 pid=28929 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="automount" exe="/usr/sbin/automount" subj=root:system_r:automount_t:s0 key=(null)
type=AVC msg=audit(1371603818.619:1148): avc:  denied  { mounton } for  pid=28929 comm="automount" path="/var/ftp" dev=dm-0 ino=20448934 scontext=root:system_r:automount_t:s0 tcontext=system_u:object_r:public_content_t:s0 tclass=dir
----

selinux-policy-2.4.6-343.el5
selinux-policy-targeted-2.4.6-343.el5
Comment 1 RHEL Product and Program Management 2013-06-20 08:58:41 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 errata-xmlrpc 2013-09-30 18:25:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1312.html

Note You need to log in before you can comment on or make changes to this bug.