Bug 971048 - Help bubble text seems to get cut off in many places.
Help bubble text seems to get cut off in many places.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Beta
: --
Assigned To: Tomer Brisker
Sachin Ghai
http://projects.theforeman.org/issues...
Verified in Upstream
: Triaged
Depends On:
Blocks: 1142809
  Show dependency treegraph
 
Reported: 2013-06-05 10:36 EDT by Corey Welton
Modified: 2016-07-27 04:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:40:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (23.98 KB, image/png)
2013-06-05 10:40 EDT, Corey Welton
no flags Details
no helptext bubble up on hovering the mouse (93.05 KB, image/png)
2015-09-01 07:27 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 3181 None None None 2016-04-22 12:12 EDT

  None (edit)
Description Corey Welton 2013-06-05 10:36:25 EDT
Description of problem:

The hover text/help bubble text seems to get cut off in many instances.


Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-ec2-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10002-44.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* openldap-devel-2.4.23-32.el6_4.1.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.15-1.el6sat.noarch
* signo-katello-0.0.15-1.el6sat.noarch


How reproducible:


Steps to Reproduce:
1.  Create a new host or two in foreman
2.  Navigate to hosts and click checkbox(es) next to host(s)
3.  Click the ensuing "Select Action" dropdown; hover over the various options; observe help text bubble.
4.  Click on a hostname and hover over the Run Puppet button

Actual results:
Help text gets cut off

Expected results:
Help text in bubble is fully readable.

Additional info:
Comment 1 Corey Welton 2013-06-05 10:40:37 EDT
Created attachment 757250 [details]
screenshot
Comment 6 Tomer Brisker 2015-08-16 07:57:50 EDT
Connecting redmine issue http://projects.theforeman.org/issues/3181 from this bug
Comment 7 Bryan Kearney 2015-08-17 07:09:28 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/3181 has been closed
-------------
Dominic Cleal
I think this is a regression from when the new top bar was added.  Back in 1.1 it used to be two separate strings.

https://github.com/theforeman/foreman/commit/dfd511ba91680bc3446b95004849cfd34d8d5ac8#diff-7dd7fbd7db2bd9e57e2abfdefecffa90L106
Comment 8 Sachin Ghai 2015-09-01 07:25:10 EDT
Verified in upstream.

foreman-proxy-1.10.0-0.develop.201508250705gitb446e0c.el6.noarch
rubygem-smart_proxy_discovery-1.0.2-1.el6.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
foreman-release-1.10.0-0.develop.201508241946git8658fa3.el6.noarch
ruby193-rubygem-hammer_cli_import-0.10.21-3.el6.noarch
ruby193-rubygem-hammer_cli_foreman_docker-0.0.3-3.el6.noarch
ruby193-rubygem-hammer_cli-0.3.0-1.201508241209git174f507.el6.noarch
ruby193-rubygem-hammer_cli_foreman_tasks-0.0.7-2.el6.noarch
ruby193-rubygem-hammer_cli_foreman_bootdisk-0.1.3-2.el6.noarch
ruby193-rubygem-hammer_cli_katello-0.0.17-1.el6.noarch

I think tooltip/help text has been removed as I no longer see that for any option under "Select Action" drop down.
Comment 9 Sachin Ghai 2015-09-01 07:27:04 EDT
Created attachment 1068968 [details]
no helptext bubble up on hovering the mouse
Comment 10 Sachin Ghai 2015-09-01 07:28:58 EDT
hey Tomer,

Could you please see comment 8 and confirm if its expected ?
Comment 11 Tomer Brisker 2015-09-01 07:37:27 EDT
The tooltip from the original bug has been removed upstream, and upon further checks this seems to have already been resolved downstream as well for Sat 6.1.
Moving to ON_QA, setting sat-6.1.1 flag as this has apparently been already resolved by 6.1.1.
Comment 12 Sachin Ghai 2015-09-01 07:42:47 EDT
Moving this to verified as per comment 11
Comment 15 errata-xmlrpc 2016-07-27 04:40:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.