Bug 971110 - switch between headpin and katello logos based on config
Summary: switch between headpin and katello logos based on config
Status: CLOSED ERRATA
Alias: None
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
(Show other bugs)
Version: 1.3
Hardware: Unspecified Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Tom McKay
QA Contact: SAM QE List
URL:
Whiteboard:
Keywords: Triaged
Depends On: 966112
Blocks: sam13-tracker
TreeView+ depends on / blocked
 
Reported: 2013-06-05 17:49 UTC by sthirugn@redhat.com
Modified: 2013-10-01 11:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 966112
Environment:
Last Closed: 2013-10-01 11:11:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Signo failed : No SAM logo (73.44 KB, image/png)
2013-08-06 14:16 UTC, Tazim Kolhar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 14:43:14 UTC

Comment 1 sthirugn@redhat.com 2013-06-05 17:54:53 UTC
Retested today:
sam 1.3.1 build from 6/3 - sign in page is good, home page logo is missing.  

Version tested:
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-cert-consumer-beast.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-headpin-1.4.2-8.el6sat.noarch
* katello-headpin-all-1.4.2-8.el6sat.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch



In headpin nightly from today, sign page logo is missing, home page logo is present.
Version Tested:
* candlepin-0.8.13-1.el6.noarch
* candlepin-cert-consumer-hp-dl120g5-01.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.13-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.74.db9f577.el6.noarch
* katello-cli-common-1.4.2-1.git.74.db9f577.el6.noarch
* katello-common-1.4.2-1.git.543.d860384.el6.noarch
* katello-configure-1.4.3-1.git.53.a9713c8.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.543.d860384.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.543.d860384.el6.noarch
* katello-headpin-1.4.2-1.git.543.d860384.el6.noarch
* katello-headpin-all-1.4.2-1.git.543.d860384.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch

Comment 3 Bryan Kearney 2013-06-07 13:18:51 UTC
signo has the either the foreman icon, or no icon. I believe this is because signo is not setting a favicon directly, but is hoping to inherit it from the / context. I would suggest that signo add an explicit favoicon. 

Asking Marek to take a look.

Comment 8 Tazim Kolhar 2013-08-06 14:16:51 UTC
Created attachment 783362 [details]
Signo failed : No SAM logo

VERIFIED :
# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-common-1.4.3-5.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-cli-common-1.4.3-4.el6sat.noarch
katello-glue-elasticsearch-1.4.3-5.el6sam_splice.noarch
katello-headpin-all-1.4.3-5.el6sam_splice.noarch
katello-cli-1.4.3-4.el6sat.noarch
katello-glue-candlepin-1.4.3-5.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-5.el6sam_splice.noarch

Comment 9 Bryan Kearney 2013-08-14 19:52:51 UTC
Snap2 is branded correctly.. moving to ON_QA.

Comment 10 sthirugn@redhat.com 2013-08-16 17:12:38 UTC
VERIFIED.  Home page signo icon is now changed to SAM logo.

Version tested:
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-21.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch

Comment 12 errata-xmlrpc 2013-10-01 11:11:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html


Note You need to log in before you can comment on or make changes to this bug.