Bug 971358 - EAP fails to start with transactions configured to be run with JDBCObject store
Summary: EAP fails to start with transactions configured to be run with JDBCObject store
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
(Show other bugs)
Version: 6.1.0
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ER1
: EAP 6.2.0
Assignee: Stefano Maestri
QA Contact:
URL:
Whiteboard:
Keywords:
: 971360 (view as bug list)
Depends On:
Blocks: 999655 1002584 1002976
TreeView+ depends on / blocked
 
Reported: 2013-06-06 11:00 UTC by Ondrej Chaloupka
Modified: 2018-12-02 16:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 16:15:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBTM-1879 Critical Closed JdbcObjectStore is not closing connection 2017-11-01 01:48 UTC
JBoss Issue Tracker WFLY-1460 Major Resolved WildFly server fails to start with transactions configured to be run with JDBCObject store 2017-11-01 01:48 UTC

Description Ondrej Chaloupka 2013-06-06 11:00:44 UTC
This bug occurs in upstream of WILDFLY and purpose of this bugzilla is possibility to track backport of functionality to the EAP 6.2.

In case that you configure transactions subsystem for running with JDBCObject store the app server fails to start because of (it seems so) a circular dependency.

You can expect the exception like:
ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 52) JBAS014612: Operation ("add") failed - address: ([("subsystem" => "transactions")]): org.jboss.msc.service.CircularDependencyException: Container jboss-as has a circular dependency: [service jboss.txn.ArjunaObjectStoreEnvironment, service jboss.txn.ArjunaRecoveryManager, service jboss.connector.transactionintegration, service jboss.cached-connection-manager, service jboss.data-source.java:jboss/datasources/JDBCObjectDS] 

My assumption came from the configuration similar to this:
<datasource jta="false" jndi-name="java:jboss/datasources/JDBCObjectDS" pool-name="JDBCObjectDS" enabled="true" use-ccm="false"> 
<connection-url>jdbc:postgresql://postgresserver.com:5432/user1</connection-url>
  <driver-class>org.postgresql.Driver</driver-class>
  <driver>postgresql-9.2-1002.jdbc4.jar</driver>
  <security>
    <user-name>user1</user-name>
    <password>user1</password>
  </security>
</datasource> 

and the transaction config looks like this
<jdbc-store datasource-jndi-name="java:jboss/datasources/JDBCObjectDS" />

Comment 1 Ivo Studensky 2013-07-30 09:49:25 UTC
*** Bug 971360 has been marked as a duplicate of this bug. ***

Comment 2 Ivo Studensky 2013-08-13 16:17:55 UTC
The attached customer case (#00889406) does not seem to be related to this issue. I am wondering, however, if they tried the hornetq journal based object store instead of the default one. It is a known feature that the default one is slow. But anyway, the case is already closed.

Comment 4 Ondrej Chaloupka 2013-09-25 08:29:41 UTC
Verified for EAP 6.2.0.ER1.

Comment 5 JBoss JIRA Server 2013-10-01 16:07:58 UTC
Michael Musgrove <mmusgrov@redhat.com> updated the status of jira JBTM-1879 to Closed


Note You need to log in before you can comment on or make changes to this bug.