Bug 971360 - EAP fails to start with transactions configured to be run with JDBCObject store
EAP fails to start with transactions configured to be run with JDBCObject store
Status: CLOSED DUPLICATE of bug 971358
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlo de Wolf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 07:06 EDT by Ondrej Chaloupka
Modified: 2013-08-28 04:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 05:49:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1460 Major Closed WildFly server fails to start with transactions configured to be run with JDBCObject store 2018-05-31 14:51 EDT

  None (edit)
Description Ondrej Chaloupka 2013-06-06 07:06:13 EDT
This bug is reported as upstream WILD FLY jira.
The functionality of JDBC Object store for transaction manager was added to EAP 6.1 as technical preview.
This bugzilla works for tracking the backport of this functionality.
I'm putting this bugzilla to Carlo because he should be responsible for backport. 
This bugzilla could be later canceled when it will be decided that the fix won't be put to EAP 6.1.1. 

In case that you configure transactions subsystem for running with JDBCObject store the app server fails to start because of (it seems so) a circular dependency.

You can expect the exception like:
ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 52) JBAS014612: Operation ("add") failed - address: ([("subsystem" => "transactions")]): org.jboss.msc.service.CircularDependencyException: Container jboss-as has a circular dependency: [service jboss.txn.ArjunaObjectStoreEnvironment, service jboss.txn.ArjunaRecoveryManager, service jboss.connector.transactionintegration, service jboss.cached-connection-manager, service jboss.data-source.java:jboss/datasources/JDBCObjectDS] 

My assumption came from the configuration similar to this:
<datasource jta="false" jndi-name="java:jboss/datasources/JDBCObjectDS" pool-name="JDBCObjectDS" enabled="true" use-ccm="false"> 
<connection-url>jdbc:postgresql://postgresserver.com:5432/user1</connection-url>
  <driver-class>org.postgresql.Driver</driver-class>
  <driver>postgresql-9.2-1002.jdbc4.jar</driver>
  <security>
    <user-name>user1</user-name>
    <password>user1</password>
  </security>
</datasource> 

and the transaction config looks like this
<jdbc-store datasource-jndi-name="java:jboss/datasources/JDBCObjectDS" />
Comment 1 tom.jenkinson 2013-07-18 12:43:46 EDT
I have a feeling this should be assigned to Stefano?
Comment 2 tom.jenkinson 2013-07-18 14:54:45 EDT
Just to also point out that the feature is currently listed as EAP62_1050 for EAP 6.2. I am not sure about the tech preview state you mention sorry?
Comment 3 Ondrej Chaloupka 2013-07-19 02:35:47 EDT
Yes, I suppose that this should be assigned to Stefano. Just I wasn't sure who will be responsible for the issue in time when I was creating the bz. As Carlo is coordinator I thought being good idea to put the bz on him.
Carlo can I reassigned the bz to Stefano?

The remark about the tech preview concerns the EAP 6.1.0 as the feature was available there but not tested. It was mentioned in doc for customers not being confused. But as was found out now the feature was not usable at all.
Comment 6 Ivo Studensky 2013-07-30 05:49:25 EDT

*** This bug has been marked as a duplicate of bug 971358 ***
Comment 7 Rostislav Svoboda 2013-08-28 04:49:06 EDT
Removing flags

Note You need to log in before you can comment on or make changes to this bug.