Bug 971518 - DHCP host file contains duplicate IP addresses [NEEDINFO]
DHCP host file contains duplicate IP addresses
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
3.0
Unspecified Unspecified
low Severity high
: Upstream M2
: 4.0
Assigned To: Maru Newby
Roey Dekel
network
:
Depends On:
Blocks: 971378
  Show dependency treegraph
 
Reported: 2013-06-06 13:23 EDT by Gary Kotton
Modified: 2016-04-26 13:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-0.3.b2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:04:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mlopes: needinfo? (gkotton)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1191768 None None None Never
OpenStack gerrit 33254 None None None Never
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Gary Kotton 2013-06-06 13:23:28 EDT
Description of problem:
There are cases when IP addresses may appear more than once in the hosts file, for example:
fa:16:3e:16:b1:62,10-0-0-3.openstacklocal,10.0.0.3
fa:16:3e:55:86:b2,10-0-0-1.openstacklocal,10.0.0.1
fa:16:3e:f9:ad:20,10-0-0-15.openstacklocal,10.0.0.15
fa:16:3e:d6:94:39,10-0-0-13.openstacklocal,10.0.0.13
fa:16:3e:7d:42:32,10-0-0-15.openstacklocal,10.0.0.15
fa:16:3e:f7:86:a6,10-0-0-16.openstacklocal,10.0.0.16
fa:16:3e:a8:d9:2e,10-0-0-19.openstacklocal,10.0.0.19

Version-Release number of selected component (if applicable):


How reproducible:
85% of the time

Steps to Reproduce:
1. deploy 10 VM's
2. delete all 10 V's via horizon
3.

Actual results:


Expected results:


Additional info:
Comment 2 Perry Myers 2013-06-09 10:39:15 EDT
Capturing some add'l info from an off-bz email thread.

There doesn't appear to be any end-user impact.  Yes, there are entries in the dhcp hosts file where the same ip address is given to multiple MAC addresses, but it looks like these MAC addresses are for machines that have already been deleted and therefore (unless we have a random case of the same MAC being used a 2nd time) there should not be any case where there are ip address conflicts.

If there are ip addr conflicts that from this scenario cause two instances to get the same ip address, that would make this bug higher in severity and we'd definitely want to address it as an async update to RHOS 3.0.  For the time being though, since it looks like a cosmetic/cleanup issue, I think this can be resolved in Havana/RHOS 4.0.
Comment 3 Gary Kotton 2013-06-09 11:16:48 EDT
The problem will arise if there is an entry that has the same MAC address. This means that a VM may not receive an IP address. The probability of this happening is very low but if it does it is a serious problem.
Comment 4 Perry Myers 2013-06-09 11:26:19 EDT
(In reply to Gary Kotton from comment #3)
> The problem will arise if there is an entry that has the same MAC address.
> This means that a VM may not receive an IP address. The probability of this
> happening is very low but if it does it is a serious problem.

Agreed.  Wouldn't that only occur if there was a 'random MAC collision'?  i.e. MAC address generation should be statistically unique, so the chances of it happening would be extremely low.
Comment 5 Gary Kotton 2013-06-09 12:07:58 EDT
The plugin will ensure that a MAC address of a new port is unique. That is, it is unique for ports that are currently defined. The chance of this happening is pretty low. I am in the process of addressing this - the idea is to validate that the mac address is unique on the dhcp agent. If the mac address is unique then the duplicate ip issue is cosmetic
Comment 12 Roey Dekel 2013-10-11 09:17:19 EDT
Verified on Havana running rhel6.5 with:
openstack-neutron-2013.2-0.3.3.b3.el6ost.noarch
python-django-horizon-2013.2-0.13b3.el6ost.noarch

I've did this twice on different machines. Installed openstack, define a network with subnetwork (I used vlans), and create and terminate 10 instances using horizon, for 13 times in a row.

This is a copy of the host file after the 13'th time:
fa:16:3e:f9:3d:87,host-192-168-238-2.openstacklocal,192.168.238.2
fa:16:3e:82:c8:60,host-192-168-238-4.openstacklocal,192.168.238.4
fa:16:3e:15:a1:2d,host-192-168-238-5.openstacklocal,192.168.238.5
fa:16:3e:99:4e:e7,host-192-168-238-6.openstacklocal,192.168.238.6
fa:16:3e:65:64:78,host-192-168-238-7.openstacklocal,192.168.238.7
fa:16:3e:62:ab:61,host-192-168-238-8.openstacklocal,192.168.238.8
fa:16:3e:87:b9:a3,host-192-168-238-9.openstacklocal,192.168.238.9
fa:16:3e:f8:20:6e,host-192-168-238-12.openstacklocal,192.168.238.12
fa:16:3e:44:e6:97,host-192-168-238-10.openstacklocal,192.168.238.10
fa:16:3e:89:cd:67,host-192-168-238-11.openstacklocal,192.168.238.11

if the chance to reproducible is 85% after doing it once, therefor the chance that it won't reproducible after 13 time is nano precent.
Comment 15 errata-xmlrpc 2013-12-19 19:04:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.