Bug 971661 - Able to trigger host UUID generation through gluster cli command
Able to trigger host UUID generation through gluster cli command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On: 961250
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 02:01 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:05 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 961250
Environment:
Last Closed: 2013-07-24 13:15:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2013-06-07 02:01:16 EDT
Description of problem:

UUID of the host is not generated (or deferred) till the time an another host is peer probed or a volume is created. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Through should be a gluster cli command to trigger the UUID generation when needed.

Additional info:

In Ovirt for GlusterFS, currently we are using IP/name(fqdn) of the host for all our operations and uniquely identify a particular host. But we are hitting lot issues due to the hosts having multiple interfaces and hence multiple ip addresses. More specifically when the hosts are peer probed through cli using different interface/bridge/ip and but added to engine with a different ip. So we have decided to go with the gluster UUID of the host for most of the operations and also to uniquely identify a particular host. The uuid will be fetched when the user adds the node to the rhsc and then stored in the database forever. In this case the vdsm reads the uuid file and returns the uuid to engine
Comment 1 Anand Avati 2013-06-07 02:02:31 EDT
REVIEW: http://review.gluster.org/5175 (glusterd: Add a cmd for generating uuid for a peer) posted (#1) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 2 Anand Avati 2013-06-10 06:26:26 EDT
REVIEW: http://review.gluster.org/5175 (glusterd: Add a cmd for getting uuid of local node) posted (#2) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 3 Anand Avati 2013-06-10 15:20:39 EDT
COMMIT: http://review.gluster.org/5175 committed in master by Anand Avati (avati@redhat.com) 
------
commit 214dccb317437dab5464456a4eb30c88444370e7
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Thu Jun 6 10:46:57 2013 +0530

    glusterd: Add a cmd for getting uuid of local node
    
    Usage: gluster system:: uuid get
    
    This is needed since we generate uuid of a node in a lazy manner. ie, we
    generate a uuid for the node only on the first volume or peer operation,
    when the node needs an external identity.  With this command, we can
    force[1] the uuid generation, without a volume or peer operation performed.
    
    [1]: Querying for uuid (or uuid get), forces uuid to come into
    existence.
    
    Change-Id: I62c8b6754117756aa4d773dd48af4ddeb1a1d878
    BUG: 971661
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/5175
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 4 Kanagaraj 2013-06-12 03:20:44 EDT
This needs to be included in 3.4 as well to work with ovirt.
Comment 5 Anand Avati 2013-06-12 06:11:52 EDT
REVIEW: http://review.gluster.org/5204 (glusterd: Add a cmd for getting uuid of local node) posted (#1) for review on release-3.4 by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 6 Anand Avati 2013-06-18 23:29:12 EDT
COMMIT: http://review.gluster.org/5204 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 7f52e08e1b09315bd4c167187b60859516d41897
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Thu Jun 6 10:46:57 2013 +0530

    glusterd: Add a cmd for getting uuid of local node
    
            Backport of http://review.gluster.org/5175 (upstream)
    Usage: gluster system:: uuid get
    
    This is needed since we generate uuid of a node in a lazy manner. ie, we
    generate a uuid for the node only on the first volume or peer operation,
    when the node needs an external identity.  With this command, we can
    force[1] the uuid generation, without a volume or peer operation performed.
    
    [1]: Querying for uuid (or uuid get), forces uuid to come into
    existence.
    
    Change-Id: I62c8b6754117756aa4d773dd48af4ddeb1a1d878
    BUG: 971661
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/5204
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Note You need to log in before you can comment on or make changes to this bug.