Bug 971825 - Storage node auto-import - Agent platform having no storage node is being auto-imported into inventory
Storage node auto-import - Agent platform having no storage node is being aut...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-06-07 06:51 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 12:13:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-06-07 06:51:29 EDT
Description of problem:
 Agent platform having no storage node is being auto-imported into inventory

Version-Release number of selected component (if applicable):
RHQ 4.8 build:bf44b14

How reproducible:
always

Steps to Reproduce:
1. Server with rhq storage installed (ip1)
2. agent installed and connected to server (ip1)
3. agent installed and connected to server (ip2)


Actual results:
both ip1 and ip2 platforms inventoried bypassing discovery queue

Expected results:
only ip1 platform is inventoried bypassing discovery queue

Additional info:
ip1: 10.16.23.133
ip2: 10.16.23.140
Comment 1 Jay Shaughnessy 2013-06-07 11:17:26 EDT
I was unable to reproduce this using Armine's environment. Although, there was something odd to start with. I was unable to uninventory the agent platform until I uninventoried the children first.  I can't explain that.

But, afterwards things worked as expected.  I don't think there is an issue with the autocommit as it explicitly works with only the parent platform of the StorageNode resource.

Unless we can recreate the issue again, I will say that this was a transient environmental issue. But, we need to keep an eye out for anything else odd in this area, that may support evidence of some kind of issue.
Comment 2 Armine Hovsepyan 2013-06-07 12:13:20 EDT
Re-tested with new environment:
10.16.23.63 server
10.16.23.63, 10.16.23.106, 10.16.23.198 agents

It must have been an environment issue. Marking bug as not-bug.

Note You need to log in before you can comment on or make changes to this bug.