Bug 971952 - libvcllo.so: undefined symbol: hb_icu_script_to_script
libvcllo.so: undefined symbol: hb_icu_script_to_script
Status: CLOSED DUPLICATE of bug 971880
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 12:37 EDT by Satish Balay
Modified: 2013-06-07 13:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 13:10:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2013-06-07 12:37:45 EDT
Description of problem:

$ oowriter 
/usr/lib64/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib64/libreoffice/program/libvcllo.so: undefined symbol: hb_icu_script_to_script


Version-Release number of selected component (if applicable):

$ rpm -qa --last libreoffice-writer
libreoffice-writer-4.1.0.0-6.beta1.fc19.x86_64 Thu 06 Jun 2013 09:08:11 PM CDT

How reproducible:

always

Steps to Reproduce:
1. F19 upgraded from F18
2. yum update
3. oowriter

Actual results:

above error

Expected results:

no error - and the application to start

Additional info:

"yum downgrade libreoffice" does not fix it

Rolling back gcc-4.8.1 update does not fix it
Comment 1 Jeff Bastian 2013-06-07 12:40:00 EDT
Apparently this is caused by a harfbuzz update; see bug 971880
Comment 2 Satish Balay 2013-06-07 12:47:42 EDT
Yeah - just noticed http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709973 via google - and 'yum downgrade harfbuzz' fixed it.


[my bugzilla search for 'hb_icu_script_to_script' didn't find bug 971880 :(]
Comment 3 Satish Balay 2013-06-07 13:05:13 EDT
libreoffice-writer-4.1.0.0-7.beta2.fc19.x86_64 from koji also works (with latest harfbuzz)! Thanks!
Comment 4 Jeff Bastian 2013-06-07 13:10:15 EDT

*** This bug has been marked as a duplicate of bug 971880 ***

Note You need to log in before you can comment on or make changes to this bug.