Bug 971880 - Harfbuzz 0.9.18-1 causes LibreOffice to crash
Summary: Harfbuzz 0.9.18-1 causes LibreOffice to crash
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: harfbuzz   
(Show other bugs)
Version: 19
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 971771 971951 971952 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-07 13:34 UTC by Princeton
Modified: 2013-06-09 03:33 UTC (History)
8 users (show)

Fixed In Version: harfbuzz-0.9.18-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-09 03:33:30 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 971795 None None None Never

Description Princeton 2013-06-07 13:34:45 UTC
Description of problem:
An upgrade to Harfbuzz 0.9.18-1 causes LibreOffice to crash upon starting. Downgrading to version 0.9.17-1 resolves the issue.

Version-Release number of selected component (if applicable):
0.9.18-1

How reproducible:
Very. Simply upgrade to Harfbuzz 0.9.18-1 and try to open a new instance of LibreOffice.

Steps to Reproduce:
1. Upgrade to HarfBuzz 0.9.18-1
2. Open a new instance of LibreOffice.

Actual results:
LibreOffice crashes.


Expected results:
LibreOffice shouldn't crash.

Additional info:
(from gdb) : 
====================================================
(gdb) run
Starting program: /usr/lib64/libreoffice/program/soffice.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/libgobject-2.0.so.0.3600.2-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/libgobject-2.0.so.0.3600.2-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[New Thread 0x7ffff782c700 (LWP 1950)]
[New Thread 0x7fffecdc2700 (LWP 1951)]
[New Thread 0x7fffe7fff700 (LWP 1952)]
[New Thread 0x7fffe71bc700 (LWP 1954)]
/usr/lib64/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib64/libreoffice/program/libvcllo.so: undefined symbol: hb_icu_script_to_script
[Thread 0x7fffe7fff700 (LWP 1952) exited]
[Thread 0x7fffe71bc700 (LWP 1954) exited]
[Thread 0x7fffecdc2700 (LWP 1951) exited]
[Thread 0x7ffff782c700 (LWP 1950) exited]
[Inferior 1 (process 1946) exited with code 0177]
====================================================

Comment 1 Parag Nemade 2013-06-07 14:04:17 UTC
Fixed libreoffice is already available on koji. http://koji.fedoraproject.org/koji/buildinfo?buildID=425097

Comment 2 Fedora Update System 2013-06-07 16:50:31 UTC
harfbuzz-0.9.18-2.fc19,libreoffice-4.1.0.0-7.beta2.fc19,webkitgtk-2.0.2-2.fc19,webkitgtk3-2.0.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/harfbuzz-0.9.18-2.fc19,libreoffice-4.1.0.0-7.beta2.fc19,webkitgtk-2.0.2-2.fc19,webkitgtk3-2.0.2-3.fc19

Comment 3 Jeff Bastian 2013-06-07 17:10:15 UTC
*** Bug 971952 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Bastian 2013-06-07 17:12:29 UTC
*** Bug 971951 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Bastian 2013-06-07 17:14:31 UTC
*** Bug 971771 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Bastian 2013-06-07 19:33:52 UTC
This also broke Tom 'spot' Callaway's Chromium build [1]

$ chromium-browser 
/usr/lib64/chromium-browser/chromium-browser: symbol lookup error: /usr/lib64/chromium-browser/chromium-browser: undefined symbol: hb_icu_get_unicode_funcs


[1] http://fedoraproject.org/wiki/Chromium

Comment 7 Jeff Bastian 2013-06-07 19:50:20 UTC
Should this bug be closed as a duplicate of bug 971795?

Comment 8 Fedora Update System 2013-06-08 02:58:19 UTC
Package harfbuzz-0.9.18-2.fc19, libreoffice-4.1.0.0-7.beta2.fc19, webkitgtk-2.0.2-2.fc19, webkitgtk3-2.0.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing harfbuzz-0.9.18-2.fc19 libreoffice-4.1.0.0-7.beta2.fc19 webkitgtk-2.0.2-2.fc19 webkitgtk3-2.0.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10363/harfbuzz-0.9.18-2.fc19,libreoffice-4.1.0.0-7.beta2.fc19,webkitgtk-2.0.2-2.fc19,webkitgtk3-2.0.2-3.fc19
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-06-09 03:33:30 UTC
harfbuzz-0.9.18-2.fc19, libreoffice-4.1.0.0-7.beta2.fc19, webkitgtk-2.0.2-2.fc19, webkitgtk3-2.0.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.