Bug 971964 - Error installing JON 3.2.x after upgrading EAP to 6.1.0.Final
Error installing JON 3.2.x after upgrading EAP to 6.1.0.Final
Status: CLOSED DUPLICATE of bug 972223
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity urgent
: ER02
: JON 3.2.0
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks: jon32-Beta-Blockers-1006862
  Show dependency treegraph
 
Reported: 2013-06-07 13:58 EDT by Simeon Pinder
Modified: 2013-09-19 00:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:10:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simeon Pinder 2013-06-07 13:58:50 EDT
Description of problem:
The latest brew builds for 3.2.x have been changed to build off of EAP 6.1.0.Final, but now JON does not install and fails to install the RHQ EAR. See below for detailed error.

Version-Release number of selected component (if applicable):
JON 3.2.x Build >= 27

How reproducible:
every time.

Steps to Reproduce:
1. pull down brew build artifacts and extract them to some directory.
2. update <install dir>/bin/rhq-server.properties to point to correct db and with agent.auto.update=true.
3. start JON server and run <install-dir>/bin/rhq-installer.sh and the following error shows up in the log.

Actual results:

P, postgresql=TIMESTAMP WITHOUT TIME ZONE}, LARGEOBJECT={oracle=BLOB, h2=BLOB, java=BLOB, sqlserver=IMAGE, postgresql=OID}]
13:39:53,180 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@3539aa21
13:39:53,182 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@4db6d08b
13:39:53,282 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [ajp] to [${rhq.server.socket.binding.port.ajp:7009}]
13:39:53,283 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@52f6c35f
13:39:53,287 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@41ed03b2
13:39:53,463 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [http] to [${rhq.server.socket.binding.port.http:7080}]
13:39:53,590 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [https] to [${rhq.server.socket.binding.port.https:7443}]
13:39:53,714 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [jacorb] to [${rhq.server.socket.binding.port.jacorb:2528}]
13:39:53,832 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [jacorb-ssl] to [${rhq.server.socket.binding.port.jacorb-ssl:2529}]
13:39:53,957 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [messaging] to [${rhq.server.socket.binding.port.messaging:4445}]
13:39:54,049 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [messaging-throughput] to [${rhq.server.socket.binding.port.messaging-throughput:4455}]
13:39:54,158 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [management-http] to [${jboss.management.http.port:6990}]
13:39:54,258 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [management-https] to [${jboss.management.https.port:6443}]
13:39:54,360 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [management-native] to [${jboss.management.native.port:6999}]
13:39:54,452 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [remoting] to [${rhq.server.socket.binding.port.remoting:3447}]
13:39:54,545 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [txn-recovery-environment] to [${rhq.server.socket.binding.port.txn-recovery-environment:3712}]
13:39:54,645 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Setting socket binding [txn-status-manager] to [${rhq.server.socket.binding.port.txn-status-manager:3713}]
13:39:54,854 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Deployment scanner turned off.
13:39:54,955 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Default transaction timeout set to 600 seconds.
13:39:55,095 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Logging category org.rhq set to [${rhq.server.log-level:INFO}]
13:39:56,250 DEBUG [org.rhq.enterprise.communications.util.SecurityUtil] {SecurityUtil.keystore-created}Keystore has been created at [/NotBackedUp/spinder/installers/jon/jon-3.2.Alpha-27/jon-server-3.2.0.ALPHA_QA/jbossas/standalone/configuration/rhq.keystore]
13:39:56,250 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] New keystore created [/NotBackedUp/spinder/installers/jon/jon-3.2.Alpha-27/jon-server-3.2.0.ALPHA_QA/jbossas/standalone/configuration/rhq.keystore] with cert domain name of [CN=localhost.localdomain, OU=RHQ, O=rhq-project.org, C=US]
13:39:56,253 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Creating https connector...
13:39:56,723 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] https connector created.
13:39:56,922 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@1f74e74b
13:39:56,923 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@7039bb6d
13:39:57,118 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Security domain [RHQDSSecurityDomain] created
13:39:57,243 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Cache container [rhq] created
13:39:57,369 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Local Cache [rhqCache] created
13:39:57,479 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Deployed Postgres JDBC driver
13:39:57,638 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Deployed Oracle JDBC driver for future use
13:39:57,773 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Created datasources
13:39:58,139 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Enabled datasources
13:39:58,389 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] JMS queue [AlertConditionQueue] created
13:39:58,565 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] JMS queue [DriftChangesetQueue] created
13:39:58,691 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] JMS queue [DriftFileQueue] created
13:39:58,800 INFO  [org.rhq.enterprise.server.installer.ServerInstallUtil] Mail service has been configured.
13:39:59,022 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@5ae051e9
13:39:59,022 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@3d21c69b
13:39:59,040 INFO  [org.rhq.enterprise.server.installer.InstallerServiceImpl] Installing RHQ EAR startup subsystem extension
13:40:00,098 INFO  [org.rhq.enterprise.server.installer.InstallerServiceImpl] Will now ask the app server to reload its configuration
13:40:00,100 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@7145cac5
13:40:00,100 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@5238d3a5
13:40:00,120 INFO  [org.rhq.enterprise.server.installer.InstallerServiceImpl] App server has been successfully asked to reload its configuration
13:40:00,127 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@3ee456d8
13:40:00,129 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@4ae23d66
13:40:05,133 DEBUG [org.jboss.as.protocol] cancelled operation (1543398742) attachment: (org.jboss.as.controller.client.impl.AbstractModelControllerClient$OperationExecutionContext@24528ddb) this: org.jboss.as.protocol.mgmt.ManagementChannelHandler@27df377e.
13:40:06,138 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@7b33cec2
13:40:06,138 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@a10a9cd
13:40:06,171 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@1591223f
13:40:06,171 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@42e3c02a
13:40:06,186 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" read-1', selector sun.nio.ch.EPollSelectorImpl@66aac993
13:40:06,187 DEBUG [org.xnio.nio] Started channel thread 'Remoting "management-client" write-1', selector sun.nio.ch.EPollSelectorImpl@5698068d
13:40:06,201 INFO  [org.rhq.enterprise.server.installer.InstallerServiceImpl] Installing RHQ EAR subsystem
13:40:06,207 ERROR [org.rhq.enterprise.server.installer.Installer] An error occurred: org.rhq.common.jbossas.client.controller.FailureException: Failed to add new subsystem [rhq-startup]: The RHQ EAR failed to be deployed
	at org.rhq.common.jbossas.client.controller.CoreJBossASClient.addSubsystem(CoreJBossASClient.java:326) [rhq-jboss-as-dmr-client-4.7.0.JON.jar:4.7.0.JON]
	at org.rhq.enterprise.server.installer.InstallerServiceImpl.deployAppSubsystem(InstallerServiceImpl.java:1073) [rhq-installer-util-4.7.0.JON.jar:4.7.0.JON]
	at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:307) [rhq-installer-util-4.7.0.JON.jar:4.7.0.JON]
	at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:115) [rhq-installer-util-4.7.0.JON.jar:4.7.0.JON]
	at org.rhq.enterprise.server.installer.Installer.main(Installer.java:56) [rhq-installer-util-4.7.0.JON.jar:4.7.0.JON]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_07]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_07]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_07]
	at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_07]
	at org.jboss.modules.Module.run(Module.java:270) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.Main.main(Main.java:411) [jboss-modules.jar:1.2.0.Final-redhat-1]



Expected results:
Successful install.

Additional info:
Comment 1 John Mazzitelli 2013-06-07 14:04:23 EDT
All this is  doing is running this method - with name == rhq-startup:

    public void addSubsystem(String name) throws Exception {
        // /subsystem=<name>:add()
        final ModelNode request = createRequest(ADD, Address.root().add(SUBSYSTEM, name));
        final ModelNode response = execute(request);
        if (!isSuccess(response)) {
            throw new FailureException(response, "Failed to add new subsystem [" + name + "]");
        }
        return;
    }

I don't see why this would fail
Comment 2 Heiko W. Rupp 2013-08-24 13:38:49 EDT
Is that still the case, Simeon?
Comment 3 Simeon Pinder 2013-08-26 02:51:12 EDT
No. This was addressed. Not sure why Charles created a new BZ for it instead of updating the existing one.  See the following two BZ's for more details, 

https://bugzilla.redhat.com/show_bug.cgi?id=972233
https://bugzilla.redhat.com/show_bug.cgi?id=975242

BUT assigning to myself and leaving this open for now to make sure that we look into this once we've rebased to make sure that i) the one-off patch stays in place after rebase or ii) is removed once we've rebased if the fix is already included in 6.1.1
Comment 4 Simeon Pinder 2013-09-18 22:10:33 EDT
Removed the JBoss Modules patch as it's no longer needed.  Closing this issue as a duplicate(972223).

*** This bug has been marked as a duplicate of bug 972223 ***
Comment 5 Akira TAGOH 2013-09-19 00:09:10 EDT
wrong bug number to duplicate?

Note You need to log in before you can comment on or make changes to this bug.