This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 971973 - [abrt] system-config-printer-1.4.1-3.fc19: newprinter.py:2624:on_tvNPDevices_cursor_changed:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)
[abrt] system-config-printer-1.4.1-3.fc19: newprinter.py:2624:on_tvNPDevices_...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:c7a58ff8091e14186c803204ba5...
:
: 981912 983328 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 14:14 EDT by kuchiman
Modified: 2013-07-23 23:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.1-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 23:26:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (974 bytes, text/plain)
2013-06-07 14:14 EDT, kuchiman
no flags Details
File: environ (1.61 KB, text/plain)
2013-06-07 14:14 EDT, kuchiman
no flags Details

  None (edit)
Description kuchiman 2013-06-07 14:14:10 EDT
Version-Release number of selected component:
system-config-printer-1.4.1-3.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
core_backtrace: 2242a070a57efbb79da50519a870c99bcd6709b2 0xa40 on_tvNPDevices_cursor_changed /usr/share/system-config-printer/newprinter.py -
dso_list:       system-config-printer-libs-1.4.1-3.fc19.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
newprinter.py:2624:on_tvNPDevices_cursor_changed:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/newprinter.py", line 2624, in on_tvNPDevices_cursor_changed
    device.menuentry = _("LPD/LPR queue '%s'") % queue
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)

Local variables in innermost frame:
widget: <TreeView object at 0x1d100a0 (GtkTreeView at 0x1d44140)>
column: <TreeViewColumn object at 0x2a8ea00 (GtkTreeViewColumn at 0x2146430)>
self: <NewPrinterGUI object at 0x1d03b40 (newprinter+NewPrinterGUI at 0x1d96e20)>
rest: None
physicaldevice: <PhysicalDevice.PhysicalDevice (,,)>
queue: u'lpd'
iter: <GtkTreeIter at 0x2afaee0>
hostport: None
device: <cupshelpers.Device "lpd">
path: <GtkTreePath at 0x288e030>
model: <TreeStore object at 0x2a908c0 (GtkTreeStore at 0x22c92c0)>
scheme: None
Comment 1 kuchiman 2013-06-07 14:14:17 EDT
Created attachment 758258 [details]
File: backtrace
Comment 2 kuchiman 2013-06-07 14:14:21 EDT
Created attachment 758259 [details]
File: environ
Comment 3 Tim Waugh 2013-06-10 07:25:31 EDT
Should be fixed upstream in commit c346c2f.
Comment 4 Fedora Update System 2013-07-02 08:54:59 EDT
system-config-printer-1.4.1-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.1-8.fc19
Comment 5 Fedora Update System 2013-07-02 21:36:16 EDT
Package system-config-printer-1.4.1-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.1-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12150/system-config-printer-1.4.1-8.fc19
then log in and leave karma (feedback).
Comment 6 Tim Waugh 2013-07-09 08:02:56 EDT
*** Bug 981912 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Popelka 2013-07-11 03:10:17 EDT
*** Bug 983328 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-07-23 23:26:39 EDT
system-config-printer-1.4.1-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.