Bug 97198 - sshd reports "setlogin failed: Function not implemented"
Summary: sshd reports "setlogin failed: Function not implemented"
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-06-11 13:55 UTC by Jonathan Kamens
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 15:18:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2003-06-11 13:55:02 UTC
After upgrading to openssh-3.6.1p2-1, I get this in my syslog when people log in:

Jun 11 09:12:47 jik sshd[13093]: error: setlogin failed: Function not implemented

The login nevertheless succeeds.  Is this a bug or an ignorable informational
message?

Comment 1 Jonathan Kamens 2003-07-30 10:46:31 UTC
The message I reported originally is gone, but this one remains, each time I log
in, with 3.6.1p2-4:

Jul 30 06:44:56 jik sshd(pam_unix)[5302]: authentication failure; logname= uid=0
euid=0 tty=NODEVssh ruser= rhost=jik.kamens.brookline.ma.us  user=jik


Comment 2 Tomas Mraz 2005-02-04 15:18:12 UTC
This depends on the pam configuration and is generally not a bug.



Note You need to log in before you can comment on or make changes to this bug.