Bug 972002 - sfcbd process SEGV on openlmi lmiip request
sfcbd process SEGV on openlmi lmiip request
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openlmi-networking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 14:37 EDT by Frank Ch. Eigler
Modified: 2016-11-30 19:31 EST (History)
10 users (show)

See Also:
Fixed In Version: openlmi-networking-0.0.9-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 04:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ABRT data dump about crash (354.48 KB, application/gzip)
2013-06-07 14:37 EDT, Frank Ch. Eigler
no flags Details

  None (edit)
Description Frank Ch. Eigler 2013-06-07 14:37:37 EDT
Created attachment 758273 [details]
ABRT data dump about crash

yum-installed unmodified openlmi* and prereqs
started sblim-sfcb service
ran lmiip from the openlmi-tools/cli-tools git

% lmiip -h vm-rawhide-64.local -u root -p PASSWORD addr show

SEGV reported in sfcbd

ABRT directory attached, including backtrace & core dump.
Automated reporting failed due to bug #958933.
Comment 1 Radek Novacek 2013-06-10 03:08:35 EDT
The crash is somewhere in openlmi-networking but the backtrace doesn't show where exactly. Could you attach result of this command executed on the managed (vm-rawhide-64.local) system:

nmcli dev list
Comment 2 Frank Ch. Eigler 2013-06-10 09:53:07 EDT
% nmcli dev list no workie, but
% nmcli dev status shows
eth0 ethernet connected
lo   loopback unmanaged

(By the way, do you support non-NM setups?)
Comment 3 Radek Novacek 2013-06-11 03:56:33 EDT
ah, nmcli arguments are different in rawhide, the command I meant is:

nmcli dev show


non-NM setups are not supported, NM is required for openlmi-networking.
Comment 4 Roman Rakus 2013-06-17 11:49:18 EDT
Seems to be same problem as in bug #973233.
Comment 5 Radek Novacek 2013-06-19 04:20:45 EDT
I think 973233 is different issue.

This bug should be fixed in openlmi-networking-0.0.9-2.fc20.

Note You need to log in before you can comment on or make changes to this bug.