python-quantum client depends on python-cliff version 1.3 or later to ensure python 2.6 compatibility.
Earlier versions result in errors like the following:
'module' object has no attribute 'compress'
(see https://bugzilla.redhat.com/show_bug.cgi?id=967297 for initial reported issue)
The python-cliff package is already in the queue to be updated (python-cliff-1.3-1.el6ost).
Please note that this bug is only for updating the dependency info in the python-quantumclient spec file to specify python-cliff version 1.3 or newer.
I've tried to verified it on Havana running rhel6.5 with:
Though the python-cliff version is:
Which is later then 1.3, but looking at the dependencies of of the neutronclient I saw that it only requiers:
python-cliff >= 1.0
Which might cause problems if it needs 1.3 or later.
As I wrote earlier it looks like some repos has been updated which might cause the proper version to be installed (python-cliff-1.4.4-1.el6ost.noarch), but without them, due to current dependency you might find yourself with older version (such as 1.0).
We are providing distribution as a whole. If we require feature from python-cliff 1.3, we can just backport the feature to 1.0 (as an example) and in that case there is no reason to require 1.3. No one cares about really checking minimal required version upstream. These are just few reasons why we don't depend on versions if at all possible and instead just provide the right packages. IMHO this bug should be closed as soon as python-cliff 1.3 is available
What do you say, Pádraig, should I explicitly require python-cliff >= 1.3 here? For some reason >= 1.0 is required already.
We should avoid explicit version deps.
The only caveat is where we need to force an update within a RHOS release.
(updates between releases will/should involve a yum update, which will
apply the required update automatically without needing the version dep).
Given RHOS 3.0 and RHOS 4.0 have cliff 1.3 in the repos already,
I'm closing this.