Bug 972055 - python-neutronclient requires python-cliff 1.3
Summary: python-neutronclient requires python-cliff 1.3
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutronclient
Version: 2.1
Hardware: Unspecified
OS: Unspecified
Target Milestone: Upstream M2
: 4.0
Assignee: Jakub Ruzicka
QA Contact: Roey Dekel
Depends On:
Blocks: 980964
TreeView+ depends on / blocked
Reported: 2013-06-07 18:55 UTC by Brent Eagles
Modified: 2019-09-09 13:26 UTC (History)
10 users (show)

Fixed In Version: python-quantumclient-2.2.1-2.el6ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, older versions of python-cliff were incompatible with Python 2.6. Consequently, python-quantumclient with Python 2.6 and older python-cliff produced errors. This fix addresses the issue by requiring python-cliff version 1.3 or higher, which provides Python 2.6 compatibility. As a result, python-quantumclient can be used with Python 2.6.
Clone Of:
: 980964 (view as bug list)
Last Closed: 2013-10-29 17:57:34 UTC
Target Upstream Version:

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 967297 0 high CLOSED "quantum security-group-rule-list" cli command doesn't work 2021-02-22 00:41:40 UTC

Internal Links: 980964

Description Brent Eagles 2013-06-07 18:55:33 UTC
python-quantum client depends on python-cliff version 1.3 or later to ensure python 2.6 compatibility. 

Earlier versions result in errors like the following:

'module' object has no attribute 'compress'

(see https://bugzilla.redhat.com/show_bug.cgi?id=967297 for initial reported issue)

Additional info:

The python-cliff package is already in the queue to be updated (python-cliff-1.3-1.el6ost).

Comment 2 Brent Eagles 2013-06-20 15:33:56 UTC
Please note that this bug is only for updating the dependency info in the python-quantumclient spec file to specify python-cliff version 1.3 or newer.

Comment 9 Roey Dekel 2013-10-13 12:06:49 UTC
I've tried to verified it on Havana running rhel6.5 with:

Though the python-cliff version is:
Which is later then 1.3, but looking at the dependencies of of the neutronclient I saw that it only requiers:
python-cliff >= 1.0
Which might cause problems if it needs 1.3 or later.

Comment 10 Roey Dekel 2013-10-17 07:54:06 UTC
As I wrote earlier it looks like some repos has been updated which might cause the proper version to be installed (python-cliff-1.4.4-1.el6ost.noarch), but without them, due to current dependency you might find yourself with older version (such as 1.0).

Comment 11 Jakub Ruzicka 2013-10-29 16:47:13 UTC
We are providing distribution as a whole. If we require feature from python-cliff 1.3, we can just backport the feature to 1.0 (as an example) and in that case there is no reason to require 1.3. No one cares about really checking minimal required version upstream. These are just few reasons why we don't depend on versions if at all possible and instead just provide the right packages. IMHO this bug should be closed as soon as python-cliff 1.3 is available

What do you say, Pádraig, should I explicitly require python-cliff >= 1.3 here? For some reason >= 1.0 is required already.

Comment 12 Pádraig Brady 2013-10-29 17:57:34 UTC
We should avoid explicit version deps.
The only caveat is where we need to force an update within a RHOS release.
(updates between releases will/should involve a yum update, which will
apply the required update automatically without needing the version dep).
Given RHOS 3.0 and RHOS 4.0 have cliff 1.3 in the repos already,
I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.