Bug 972353 - network.service doesn't work after installation, missing "/etc/sysconfig/network"
network.service doesn't work after installation, missing "/etc/sysconfig/netw...
Status: CLOSED DUPLICATE of bug 965841
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 15:49 EDT by Jimmy Dorff
Modified: 2013-06-11 22:08 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 11:05:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jimmy Dorff 2013-06-08 15:49:03 EDT
Description of problem:
Anaconda isn't creating the file "/etc/sysconfig/network", which it did on Fedora 18 and previous.

Version-Release number of selected component (if applicable):
Fedora 19 Beta release

How reproducible:
Every time on both physical hardware and KVM installations

Steps to Reproduce:
1. Kickstart installation:
------
network --bootproto dhcp

%post
/bin/systemctl enable network.service
/bin/systemctl disable NetworkManager.service
------

Actual results:
There is no "/etc/sysconfig/network" file and network.service does not function. You have no network connectivity.

Expected results:
In Fedora 18 and previous, the file "/etc/sysconfig/network" was created and contained:
------
# Generated by anaconda
NETWORKING=yes
------
In Fedora 18, network.service worked as expected.

Additional info:
As a workaround, one can manually create the missing file.
Comment 1 Tom Horsley 2013-06-08 19:49:37 EDT
Yep, I ran into this as well. The biggest problem is that things just mysteriously don't work with no obvious error indication until you go low level and start running individual ifup commands, then you finally see a message on stdout about the missing file (which is real easy to fix, it is just real hard to find).
Comment 2 Jimmy Dorff 2013-06-09 00:41:27 EDT
Changing the title slightly after talking with folks at SELF. The install method doesn't really matter, the bottom line is that anaconda doesn't create this file anymore. 

Perhaps it should be created by something else? I don't care how it is fixed, but I do think that enabling network.service should still work the same as in the past.
Comment 3 Cristian Sava 2013-06-09 04:10:28 EDT
It's more buggy.
I reported back in May: https://lists.fedoraproject.org/pipermail/test/2013-May/115582.html
Still the name of the file ifcfg-... does not match the interface name (eth0, p5p1, ...) in some install cases, so expect more networking related problems (not only "network" file missing). Someone must fix these before F19 is out.
Comment 4 Radek Vykydal 2013-06-10 06:50:35 EDT
We put writing-out /etc/sysconfig/network in anaconda back. It should be in F19 TC2 http://serverbeach1.fedoraproject.org/pub/alt/stage/19-TC2/ .

As for biosdevname (p4p1) vs. new predictable systemd device naming (enp5s0), we are working on that. The latter is being added to dracut/initramfs which should solve one subset of the issues but there seems to be more to be done to get the naming in accord completely.
Comment 5 Jimmy Dorff 2013-06-10 11:05:42 EDT
Great! I've retested with TC2 and network.service worked as I expected.
Comment 6 Adam Williamson 2013-06-11 22:08:13 EDT

*** This bug has been marked as a duplicate of bug 965841 ***

Note You need to log in before you can comment on or make changes to this bug.