Bug 965841 - anaconda no longer creates /etc/sysconfig/network, systems without NetworkManager do not bring up network
anaconda no longer creates /etc/sysconfig/network, systems without NetworkMan...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 972353 (view as bug list)
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-05-21 16:21 EDT by Orion Poplawski
Modified: 2013-06-12 17:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.30.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 17:48:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-05-21 16:21:00 EDT
Description of problem:

anaconda no longer creates /etc/sysconfig/network.  This means that systems without NetworkManager do not bring up the network without:

echo NETWORKING=yes > /etc/sysconfig/network

Version-Release number of selected component (if applicable):
19.28-1

See also bug 895900 (which is very hard to read).
Comment 1 Radek Vykydal 2013-05-22 04:33:11 EDT
I have a patch for this issue (bug 957897) to be included post Beta.
Comment 2 Adam Williamson 2013-05-29 21:58:32 EDT
It's now post-Beta. This looks like something we'd definitely want to fix for final, so nominating as freeze exception.
Comment 3 Adam Williamson 2013-05-30 14:18:47 EDT
Discussed at 2013-05-30 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . Accepted as a freeze exception issue: this might be blocker if minimal installs still used network.service by default, but they don't. Still, this could be bad for people who are using a kickstart to install without NM.
Comment 4 Orion Poplawski 2013-06-10 22:54:01 EDT
Confirmed that this is fixed in 19.30.3
Comment 5 Adam Williamson 2013-06-11 22:08:13 EDT
*** Bug 972353 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2013-06-12 17:48:36 EDT
19.30.3 has been pushed stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.