Bug 972446 - F2FS kernel module not built
F2FS kernel module not built
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
21
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 1176538 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 09:38 EDT by Rolf Fokkens
Modified: 2015-01-12 19:05 EST (History)
13 users (show)

See Also:
Fixed In Version: kernel-3.17.8-200.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-10 21:57:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Fokkens 2013-06-09 09:38:06 EDT
Description of problem:
fs2fs tools are available, but the f2fs driver is not available in the kernel

Version-Release number of selected component (if applicable):
kernel-3.9.4-200.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. user mkfs.fsf2 (f2fs-tools) to buld a fsf2 filesystem
2. try to mount it
3. Notice the lack of kernel support

Actual results:
Lacke of kernel support

Expected results:
mounted FS

Additional info:
bug 922966
Comment 1 Josh Boyer 2013-06-10 11:17:07 EDT
We don't plan on enabling this in the generic kernel.
Comment 2 Jens Puhr 2014-03-01 11:50:54 EST
F2FS seems to have an outstanding performance in certain common workloads:

http://www.phoronix.com/scan.php?page=article&item=linux_314_ssdfs&num=1

I would also ask to enable the respective kernel module.
Comment 3 Orion Poplawski 2014-12-21 22:07:27 EST
Perhaps it could go into kernel-modules-extra now that we have that?
Comment 4 lnx.usr 2014-12-22 00:48:42 EST
Okay, you bunch of redhat morons really deserve negative PR as seen on http://www.phoronix.com/scan.php?page=news_item&px=MTg3MDQ 

Its just amazing how some distro and company can be hostile to their users and especially enthusiasts willing to try new technologies here and there. Your bug handling is fucked. And even Ubuntu more sane these days - they supply F2FS by default.
Comment 5 Orion Poplawski 2014-12-22 09:53:53 EST
lnx.usr - Your tone and language are completely inappropriate.
Comment 6 Marcos Mello 2014-12-22 10:12:10 EST
(In reply to Orion Poplawski from comment #3)
> Perhaps it could go into kernel-modules-extra now that we have that?

If it is not possible include it in kernel-modules, then yes please.
Comment 7 Gerald Cox 2014-12-22 10:44:38 EST
I plan on opening a new ticket after feedback from the Devel mailing list.  I don't believe requiring uses to install kernel-modules-extra is the way to go on this.  If it's good enough for Ubuntu (which is a distribution aimed at new linux users) it is certainly good enough for Fedora.
Comment 8 Josh Boyer 2014-12-22 11:20:44 EST
*** Bug 1176538 has been marked as a duplicate of this bug. ***
Comment 9 Marcos Mello 2014-12-22 13:47:57 EST
Dave says it works pretty well: http://youtu.be/DxZzSifuV4Q?t=21m32s
Comment 10 Josh Boyer 2014-12-22 16:44:00 EST
Thanks to everyone that has contributed productive information so far.  We'll take a look at this again in a couple of weeks.
Comment 11 Josh Boyer 2014-12-29 15:57:16 EST
I've enabled this in Fedora git.  It will be in the next build of the f20-rawhide kernels.
Comment 12 Fedora Update System 2015-01-09 08:09:55 EST
kernel-3.17.8-300.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.17.8-300.fc21
Comment 13 Fedora Update System 2015-01-09 08:10:48 EST
kernel-3.17.8-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.17.8-200.fc20
Comment 14 Fedora Update System 2015-01-09 22:00:11 EST
Package kernel-3.17.8-200.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.17.8-200.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0515/kernel-3.17.8-200.fc20
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2015-01-10 21:57:49 EST
kernel-3.17.8-300.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-01-12 19:05:32 EST
kernel-3.17.8-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.