Bug 972544 - term-ansicolor 1.2.2 needs tins gem
term-ansicolor 1.2.2 needs tins gem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygem-term-ansicolor (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Klepek
Fedora Extras Quality Assurance
:
: 996139 (view as bug list)
Depends On: 996489
Blocks: 919574 993227 993365 996139
  Show dependency treegraph
 
Reported: 2013-06-09 21:40 EDT by Mamoru TASAKA
Modified: 2014-03-15 08:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-term-ansicolor-1.2.2-3.fc21, rubygem-term-ansicolor-1.2.2-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-15 08:50:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2013-06-09 21:40:42 EDT
Description of problem:
term-ansicolor 1.2.2 needs tins (~> 0.8) gem, which is not yet available on Fedora.


Version-Release number of selected component (if applicable):
rubygem-term-ansicolor-1.2.2-1.fc19.noarch

How reproducible:
100%


Steps to Reproduce:
1. See below
2.
3.

Actual results:
<mock-chroot>[root@localhost /]# rpm -q rubygem-term-ansicolor
rubygem-term-ansicolor-1.2.2-1.fc19.noarch
<mock-chroot>[root@localhost /]# ruby -e "gem 'term-ansicolor'"
/usr/share/rubygems/rubygems/dependency.rb:296:in `to_specs': Could not find 'tins' (~> 0.8) among 6 total gem(s) (Gem::LoadError)
	from /usr/share/rubygems/rubygems/specification.rb:1196:in `block in activate_dependencies'
	from /usr/share/rubygems/rubygems/specification.rb:1185:in `each'
	from /usr/share/rubygems/rubygems/specification.rb:1185:in `activate_dependencies'
	from /usr/share/rubygems/rubygems/specification.rb:1167:in `activate'
	from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:48:in `gem'
	from -e:1:in `<main>'


Additional info:
Comment 1 Vít Ondruch 2013-08-13 10:03:39 EDT
*** Bug 996139 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2013-08-13 12:01:00 EDT
rubygem-tins-0.8.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-tins-0.8.4-1.fc19
Comment 3 Fedora Update System 2013-08-14 22:36:09 EDT
rubygem-tins-0.8.4-1.fc19 has been pushed to the Fedora 19 testing repository.
Comment 4 Vít Ondruch 2013-08-23 11:54:24 EDT
Going to fix this, in F20 and Rawhide. Not sure if it is worth of pushing into F18/F19, since the updates are stuck in Bodhi.
Comment 6 Jan Klepek 2013-11-03 14:04:14 EST
more complicated for epel 5/6 :/ tins is not available for epel and same applies for packages in tins requires, work on this topic started, will take longer time before term-ansicolor is available for epel 5/6.

f18/f19 will be available during next week
Comment 7 Jan Klepek 2014-03-15 08:50:13 EDT
fixed already for some time.

Note You need to log in before you can comment on or make changes to this bug.